RTX 2080 SUPER and Ubuntu 24.04 LTS: prime-select error and setup issues

Hi everyone,

I recently reformatted my computer and installed Ubuntu 24.04 LTS, but I’m encountering issues with my RTX 2080 SUPER graphics card. I notice occasional random freezes while typing, and my secondary monitor flickers when displaying new content or scrolling. Additionally, I can also only access my desktop through Wayland, though I’m unsure if this problem is related.

After logging in, I began setting up the necessary drivers and applications, which include NVIDIA-related software. I’ve also blacklisted the nouveau drivers, although I later learned that this might be unnecessary:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt install nvidia-drivers-535

sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist.conf"
sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist.conf"
sudo update-initramfs -u

To verify the setup, I checked the outputs of nvidia-smi, nvidia-settings, and lspci:

lspci -v | grep VGA
> 01:00.0 VGA compatible controller: NVIDIA Corporation TU104 [GeForce RTX 2080 SUPER] (rev a1) (prog-if 00 [VGA controller])

The missing panel options in nvidia-settings gave me a hint of what was happening, but I could not switch to nvidia using prime-select:

sudo prime-select query
> on-demand

sudo prime-select nvidia
> Error: no integrated GPU detected.

Despite trying some other fixes like switching between different NVIDIA driver versions (550, 525, 535) or even reformatting and reinstalling Ubuntu, I’ve had no success. Any suggestions or guidance would be greatly appreciated.

I’ve attached the nvidia-bug-report.log for more detailed information.

Thank you in advance for your help!


Hardware & Other Settings:

SO: Ubuntu 24.04 LTS
Kernel: Linux 6.8.0-31-generic
Processor: Intel Core i9-9900KF 3.60GHz (5.0GHz Turbo) (does not include integrated graphics)
Graphics: Asus Rog Strix GeForce RTX 2080 SUPER/PCIe/SSE2 8GB GDDR6 256Bit
NVIDIA Driver Version: 535.171.04
Motherboard: ASRock Z390 Extreme 4 Chipset Z390 Intel LGA 1151 ATX DDR4
Memory: DDR4 Corsair Vengeance RGB Pro (4x8GB) 3600MHz
Water Cooler: Corsair H115i Pro RGB 280mm
Power Supply: XFX 650W XTR Series ATX/EPS Full Modular 80PLUS GOLD, P1-650B-BEFX
Storage: SSD Corsair Force MP510 960GB M.2 2280 NVMe and HD Seagate Barracuda 1TB (only used as extra storage space, mounted on /media/data)


Attached Files:

nvidia-bug-report.log (2.7 MB)

Can this problem be related to my current kernel version, 6.8.0-31-generic?

I changed modeset=1 to modeset=0 inside nvidia-graphics-drivers-kms.conf and something happened.

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
> /etc/modprobe.d/blacklist.conf:blacklist nvidiafb
> /etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
> /etc/modprobe.d/nvidia-graphics-drivers-kms.conf:# This file was generated by nvidia-driver-535
> /etc/modprobe.d/nvidia-graphics-drivers-kms.conf:options nvidia-drm modeset=1
sudo update-initramfs -u

Now I can see all the options I wanted inside nvidia-settings, but my system is constantly crashing and showing:
“Oh no! Something has gone wrong. A problem has occurred and the system can’t recover. Please log out and try again.”

By upgrading Ubuntu gnome was switched to a wayland session, that’s why you had reduced information in nvidia-settings. By setting modeset=0 you disabled wayland, now running Xorg again.
Since the new kernel includes the simpledrm driver, please disable it by setting nvidia-drm.modeset=1 as kernel parameter. Then check if your system works better by switching to Xorg in gnome directly
https://desklog.io/help/productivity/how-to-enable-disable-wayland-on-ubuntu-22-04-desktop/
Since you only have one gpu, prime-select is not applicable.

Apologies for the delayed response. I followed the steps you suggested to fix the issue, but unfortunately, it’s still not resolved. Could you please confirm if I did everything correctly?

  1. I reverted to my previous “functional” state:
sudo nano etc/modprobe.d/nvidia-graphics-drivers-kms.conf
> Changed 'options nvidia-drm modeset=0' to 'options nvidia-drm modeset=1'

sudo update-initramfs -u
  1. I disabled SimpleDRM driver:
sudo nano /etc/default/grub
> Changed 'GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"' to 'GRUB_CMDLINE_LINUX_DEFAULT="quiet nvidia-drm.modeset=1"'

grub-mkconfig -o /boot/grub/grub.cfg
  1. I disabled Wayland:
sudo nano /etc/gdm3/custom.conf
> Changed "#WaylandEnable=false" to "WaylandEnable=false"

reboot

Despite those, my system is (again) constantly crashing and showing: “Oh no! Something has gone wrong. A problem has occurred and the system can’t recover. Please log out and try again.”.

Did I miss anything? What could I try next?

Please create a new nvidia-bug-report.log after this happens.