RTX 3070 buzzing noise on Ubuntu 20.04 - 460.67 driver

Okay, so for the past week I’ve been trying to get my Nvidia driver working but to no avail. I’ve read and tried pretty much everything online.

Specs:
Asus G15 G513Q-HF010T
CPU: AMD Ryzen R7 5800H with Radeon Graphics
GPU: NVIDIA RTX 3070

OS:
Linux Mint 20.1 Ulyssa
Kernel: 5.4.0-58-generic

It’s a dual boot with Windows 10 already installed on it.
So I Installed Mint (Cinnamon) and the first thing I did was to try and install/enable the Nvdia driver from the “Driver Manager”, it was installed and after the reboot was stuck to the black screen with the “_” at the top left corner . All I can do is ALT+CTRL+F1 to enter the terminal. Also tried installing the drive as per the steps at:
## Chapter 4. Installing the NVIDIA Driver in NVIDIA Accelerated Linux Graphics Driver README and Installation Guide for 460.39 driver (sorry , can’t add more links in the tread)
Downloaded from here:
nvidia.com/Download/driverResults.aspx/170134/en-us
Before that I tried installing this one instead:

(but the whole OS was re-install after lots of troubleshooting so I could start fresh)

I’m attaching 1 file with all the info as can’t attach more than that (let me know if anything else is required):
nvidia-troubleshoot.txt (1.7 MB)

Search for to find easier:

NVIDIA BUG REPORT
KERNEL LOG:
XORG-CONF
NVIDIA-SMI
XORG.1.LOG
LSCPI-VGA
LSB_RELEASE
DRIVERS/MODULES
NOUVEAU BLACKLIST

The PCI BusID number in xorg.conf was added by manually by me as apparently it helped in some cases with this issue (not here though).
Also tried adding “AllowEmptyInitialConfiguration” to the “Device” section.
Removing the whole xorg.conf file makes it even worse as I again get stuck on blackscreen but the “" is blinking and when I try ALT+CTRL+F1 the login appears for a second and then it’s gone right away, like it’s constantly refreshing and going back to "”. So in order to get back to the terminal I run into recovery mode and re-instate the xorg.conf.
Also tried adding nouveau.modeset=0 to GRUB upon booting (tested with “nomodeset” as well).
blacklist-nvidia-nouveau is also set in /etc/modprobe.d/ (in attached)

According to the Xorg.1.log (in attached), the NVIDIA driver and GPU are detected and properly (grep -i nvidia) and with the correct PCI.

I read few threads that updating the Kernel is required but I believe this is the latest version for Mint ?

One thing to note that during the driver installation there was a warning:
“Unable to determine the path to install the libglvnd EGL vendor library config files. Check that you have pkg-config and the libglvnd development libraries installed, or specify a path with --glvnd-egl-config-path.”

After reading on that I checked in /usr/lib/xorg/modules/modules/drivers, which was missing the “nvidia_dr.so” file.
Same for: /usr/lib/xorg/modules/extensions/libglxserver_nvidia.so.460.39
So I installed “apt install build-essential libglvnd-dev pkg-config”, after which the files were there. (in attached)
Also checked and followed:
## Chapter 8. Common Problems in the same Guide mentioned at the begging.

Not sure about this in the Xorg.1.log:

[   796.419] (--) NVIDIA(GPU-0): DFP-0: disconnected
[   796.419] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[   796.419] (--) NVIDIA(GPU-0): DFP-0: 2670.0 MHz maximum pixel clock

[   796.419] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   796.419] (==) NVIDIA(0):     will be used as the requested mode.

At this point only the terminal is working and no GUI.

Apologies for the ridiculously long thread but I think having the more info the better.
Any help is greatly appreciated as I am kinda stuck and not sure what I’m missing.

Don’t use the .run file installer from nvidia. Use a distro package.
So run the installer with the --uninstall option first.
Then look for hints in this thread:

In short:

Thanks for the reply Mart.

So long story short, I’ve ended up installing Ubuntu 20.04 (KDE Plasma) instead of the Mint. Followed all the steps and managed to get the Nvidia running.

However, I can hear a buzzing noise from the GPU when performing even the most simple tasks (opening programs, scrolling, etc), basically every time the GPU is working. It’s not loud but definitely not normal.
I’m attaching the nvidia-bug-report, as I’m not even sure where to start troubleshooting this.

nvidia-bug-report.log (1.5 MB)
(perhaps some kind of real-time monitoring log might help ?)

It’s not a hardware issue as it’s working perfectly fine on Windows.

Maybe even newer kernel required ? Currently running 5.10.14-051014-generic

nvidia-smi:

±----------------------------------------------------------------------------+
| NVIDIA-SMI 460.67 Driver Version: 460.67 CUDA Version: 11.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce RTX 307… Off | 00000000:01:00.0 Off | N/A |
| N/A 45C P8 11W / N/A | 428MiB / 7982MiB | 8% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 1146 G /usr/lib/xorg/Xorg 45MiB |
| 0 N/A N/A 1707 G /usr/lib/xorg/Xorg 170MiB |
| 0 N/A N/A 1921 G /usr/bin/kwin_x11 80MiB |
| 0 N/A N/A 1924 G /usr/bin/plasmashell 59MiB |
| 0 N/A N/A 4931 G …AAAAAAAAA= --shared-files 52MiB |
| 0 N/A N/A 6057 G …phinLVdpvH.7.slave-socket 3MiB |
±----------------------------------------------------------------------------+

Let me know if any further information is needed.
Appreciate the help!

AFAIK the fans on Optimus laptops are completely controlled by the BIOS.
Might look around there, if you can change some settings.

From my experience, there are two sources of ‘buzzing’, either fans or static noise from speakers. The first one from heat, the latter one from bad electric design of the notebook.
The difference to windows is the mode you’re in now, prime output aka ‘performance’, i.e. everything is running on the nvidia gpu. For a more windows-like behaviour, use sudo prime-select on-demand and learn how to run tasks on the nvidia gpu selectively. Then try to find the buzzing source, comparing with windows.

Thank you both!

I do not think it’s the fans as they can be heard spinning while benchmarking (which is OK). I’ve ran glmark2 and had watching nvidia-smi + nvtop at the same time. During the test, the noise occurs sometimes and it’s not constant, I’m attaching a short a video that might be of help to get better understanding of the issue.

The timeframes when it can be heard are:
08-17 sec
27-48 sec

It’s like a high pitch static noise that changes depending on the tests while the benchmark is running. (speakers are muted). I’m using glmark2 just so can replicate the issue, but it can be also heard while performing more simple tasks, like opening various apps.

Also, not sure if related but when the laptop stays idle and automatically suspends after while, when waking it up and trying to log back in it hangs after entering the password. Almost full black screen but can still barely see the log in password field.

Not sure if any of the issues might be reflected in a log somewhere, as its hard to troubleshoot with no actual data ?

As for prime-select on-demand , does that mean that I need to remove nouveau_modset=0 from GRUB, as it’s currently added ? And would you please advise on how can I select individual apps to run on the Nvidia GPU as I couldn’t find a way…

Thank you again!

No, leave the nouveau parameter.
https://download.nvidia.com/XFree86/Linux-x86_64/460.39/README/primerenderoffload.html