RTX 3050 UBUNTU 22.04 Laptop lag non-stop on with normal work

nvidia-bug-report.log.gz (490.1 KB)

Screenshots.zip (151.6 KB)

Something went wrong with the nvidia-bug-report.log, please try uploading it again.

nvidia-bug-report.log.gz (483.0 KB)

You’re running a Wayland session on the intel igpu with an external monitor connected to the nvidia gpu. Does the lag only occur on the external monitor or also on the internal display? Does it go away when you disconnect the external monitor?

It occur on all monitors. Yes, it go away when I disconnect external monitors.

Looks like the driver is not clocking up the nvidia gpu so it can properly drive two monitors. Should be a driver bug though I also don’t know how to work around it using wayland. Please send your description and bug-report.log to linux-bugs[at]nvidia.com
Maybe it will get some attention there.

Please check if nvidia-smi -lgc works for you to raise the clocks manually, e.g.
nvidia-smi -lgc 500,2100
then check nvidia-smi -q that the clocks have raised. Maybe that will remove the lag.

Sadly, there’s no difference. Still the same.

Unfortunately, the memory clocks don’t rise.

so there’s another way to do it ?

Likely not. The counterpart for lgc is lmc but usually not supported on mobiile chips (nvidia-smi -lmc 1600,1600).
You might check if the old powermizer setting still work and apply to Wayland (I don’t think so) with kernel parameter

nvidia.NVreg_RegistryDwords="PowerMizerEnable=0x1; PowerMizerDefaultAC=0x2; PowerMizerLevelAC=0x2; PerfLevelSrc=0x3322;"

It’s not a command but a kernel parameter.

So how to modify this parameters ?


Still the same. They don’t reply at linux-bugs@nvidia.com

If you open the nvidia-settings app and click on PowerMizer, here you can select Prefer Maximum Performance. Does this help?


1 Like

@anlmat Your suggestion helped the lag significantly (though there’s still a tiny bit of lag remaining). Thank you!

Edit: Once I went to “PRIME Profiles” in nvidia-settings app and chose “NVIDIA (Performance Mode)”, the remaining lag disappeared completely!