Running a Python Script

I am running the Isaac Sim container through an AWS instance.
When I enter into the container and try to run a python script though, I get some errors.
I followed the introduction tutorials to the python script, but it did not help my case.
As an example when I run this python script, I get the following error. I get similar(but not the same error) errors with any python script I run inside the isaac-sim directory inside the container.
When I run that file, this is the message I get:

Omniverse Kit cannot be run as the root user without the --allow-root flag.
Running as root should not be necessary under most circumstances.
Doing this may cause kit to encounter errors when running as a normal user again.
Traceback (most recent call last):
File “”, line 22, in
kit = OmniKitHelper(config=CONFIG)
File “/isaac-sim/exts/omni.isaac.python_app/omni/isaac/python_app/”, line 109, in init
self.loop_runner = _loop.acquire_loop_interface()
RuntimeError: Failed to acquire interface: omni::kit::IRunLoopRunnerImpl (pluginName: nullptr)
There was an error running python

Please note this is being run inside the docker container isaac-sim directory linked to an AWS instance. I thought by default Python is present inside the isaac-sim package. I have also enabled all the necessary extensions. What is this error? How should I resolve it?
Thank you for your help!

Hi, you will need to use the --allow-root flag when running Isaac Sim in a docker container.