Segementation fault when following Basic Time Stepping tutorial

Hi, I have encountered an error when following the tutorial “ISAAC SIM PYTHON SAMPLES”, at URL: Getting Started — Omniverse Robotics documentation.

When running python simple/time_stepping.py, the following error is raised:
[Warning] [omni.kit.app.plugin] --carb/app/extensions/folders2/0="/isaac-sim/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/exts": prefix ‘–carb/’ is deprecated. Override should be --/app/extensions/folders2/0="/isaac-sim/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/exts"
[Warning] [omni.kit.app.plugin] --carb/app/extensions/folders2/1="/isaac-sim/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/extsPhysics": prefix ‘–carb/’ is deprecated. Override should be --/app/extensions/folders2/1="/isaac-sim/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/extsPhysics"
[Warning] [omni.kit.app.plugin] --carb/app/extensions/folders2/2="/isaac-sim/_build/linux-x86_64/release/exts": prefix ‘–carb/’ is deprecated. Override should be --/app/extensions/folders2/2="/isaac-sim/_build/linux-x86_64/release/exts"
Omniverse Kit cannot be run as the root user without the --allow-root flag.
Running as root should not be necessary under most circumstances.
Doing this may cause kit to encounter errors when running as a normal user again.
Segmentation fault (core dumped)

Running in docker, followed all previous steps about conda env setup.
Have anyone encountered something similar before?

Hi, the --allow-root is needed when running Isaac Sim in a container. This flag has already been added to the runheadless.sh file in the /isaac-sim folder of the container.

Thank you for your input, @Sheikh_Dawood. But I am a bit confused about running it headlessly.

The way I am running the container is through the command:
sudo docker run --entrypoint ./runapp.sh --gpus all -e “ACCEPT_EULA=Y” --rm -v /tmp/.X11-unix:/tmp/.X11-unix -v /etc/localtime:/etc/localtime:ro -e DISPLAY=unix${DISPLAY} --network=host nvcr.io/nvidia/isaac-sim:2020.2.2_ea

Then it runs the Omniverse Kit window and starts the container. I am connecting to the docker container then with the VS code and executing the commands from the samples tutorial.

Is there another way to run the docker, such that it has –allow-root flag enabled?

The flag is also enabled in the runapp.sh. Do you run the samples commands in the same docker container too?

yes, of course. what can be the issue then?

Can you list the steps you took to get the error? How was Anaconda installed and setup?
Was running conda activate isaac-sim successful for you?

Here’s workaround you could try:

  1. In the container, edit the file: /isaac-sim/_build/linux-x86_64/release/exts/omni.isaac.synthetic_utils/omni/isaac/synthetic_utils/scripts/omnikit.py
  2. Add "--allow-root", at line #112

The section should look like this:

def _start_app(self):
    args = [
        os.path.abspath(__file__),
        "--allow-root",
        f'--merge-config={self.config["experience"]}',

@Sheikh_Dawood thank you. The workaround helped.

1 Like