Same fps with i915 or rtx 2060?

Hello,
I just installed Debian stable with the linux kernel 5.10 and the nvidia-driver 460 (it is the version the nvidia-driver chose to install).

Please find the attached nvidia bug report.

nvidia-bug-report.tar.gz (266.2 KB)

I have 3 issues:

  1. When trying this url “wirple_dot_com/bmark/” (replace dot with an actual dot, as a new user I am limited to 1 url link in my post), fps are around 50-80fps and other javascript 3d libs examples (Threejs…), I have the same performance using my i915 or my rtx2060.
    To use the rtx, I launch firefox with primusrun /path/to/firefox
    I should have a fps increase. My laptop (Asus ROG) has a 144Hz screen. it should not be capped much below for such a simple scene, especially with the RTX. primusrun glxgears -info shows nvidia card is used.
    I also have some screen glitches at times, very fast and random as it seems.

  2. HDMI screen doesn’t work under Linux, but works fine under Windows. That is a real problem for me, because most of the time, the laptop is for development work.

  3. Any attempt to upgrade the linux kernel to, say 5.16 or 5.18 with matching kernel header via backports leads to install errors (dkms related). But that point is non essential for me, if the two above can be solved.

Please note,the kernel module and everything is installed and no errors are thrown (with the kernel 5.10). No xorg config file is created either.

Can you help please?

Thanks

Here is a new log of this morning.

nvidia-bug-report.log (586.0 KB)

On a 3D website under Windows, the gtx 2060 runs at 144fps (max Hz of my screen) while on Linux 50fps (even with the option __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia firefox). Which means the RTX 2060 doesn’t kick in.

Any help? Kernel 5.10 seems my only option as of now, 5.18 rejects driver 470.

I tried the 515 driver from Nvidia, no luck either.

And still no HDMI while it works out of the box on Windows. That point is really annoying.

What are my options?

Thanks,

The nvidia kernel modules are broken so it’s not used at all:

[    6.917051] nvidia: loading module not compiled with retpoline compiler.
[    6.926227] nvidia_modeset: loading module not compiled with retpoline compiler.
[    6.926555] nvidia_modeset: Unknown symbol nvidia_get_rm_ops (err -2)
[    6.926571] nvidia_modeset: Unknown symbol nvidia_register_module (err -2)
[    6.926586] nvidia_modeset: Unknown symbol nvidia_unregister_module (err -2)

How did you install the driver? Please purge it and install the 515 driver, then create a new nvidia-bug-report.log.

Will do that right now

I guess beforehand you should also reinstall the kernel headers, might be broken.
sudo apt install --reinstall linux-headers-$(uname -r)

@generix : Yesterday, I tried with the 5.18 backported kernel for my debian stable.
But all my attempts failed.

So I decided to remove all the kernels and stick with 5.10, which happens to be the one stable uses by default.

Now, I can only access driver 460 apparently, but at least, the driver installs without error.

I just purged my computer, rebooted, and reinstalled 5.10 headers with your command + nvidia driver. Nothing else.

Still no luck with nvidia-settings, but nvidia-smi shows the card. lspci -k | grep -A 3 VGA tells me that nvidia is the driver in use for the 2060.

Please find attached the updated bug report
nvidia-bug-report.tar.gz (220.4 KB)

Still the same errors on module loading and the nvidia-drm module is missing completely. This won’t work. Why can’t you access anything else than driver 460? Again, how did you install the driver?

Starting from a fresh Debian stable install, I follow this guide
https://wiki.debian.org/NvidiaGraphicsDrivers#NVIDIA_Proprietary_Driver

sudo apt-get install nvidia-driver firmware-misc-nonfree

And reboot.

I will try with the backports alternative right now

Just tried the backports:
Purge beforehand, reinstall the linux-headers, reboot.
Now, I run 470. The system made me update modprobe, but still no luck with nvidia-settings.

nvidia-bug-report.tar.gz (221.1 KB)

Secure boot and fast boot are disabled.

There’s something broken in your build system. Please post the output of
cc -v

Sure:

Using built-in specs.
COLLECT_GCC=cc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/10/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none:amdgcn-amdhsa:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Debian 10.2.1-6’ --with-bugurl=file:///usr/share/doc/gcc-10/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,m2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-10 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-bootstrap --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --enable-libphobos-checking=release --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-10-Km9U7s/gcc-10-10.2.1/debian/tmp-nvptx/usr,amdgcn-amdhsa=/build/gcc-10-Km9U7s/gcc-10-10.2.1/debian/tmp-gcn/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu --with-build-config=bootstrap-lto-lean --enable-link-mutex
Thread model: posix
Supported LTO compression algorithms: zlib zstd
gcc version 10.2.1 20210110 (Debian 10.2.1-6)

Ah, I replaced ld with mold. Just remembered that.

Let me undo that modification and retry.

Ok,

Now nvidia-settings is back: mold was the culprit (but I need it for my work so I will find a workaround in my IDE).

On Chromium I get the same result as Windows 144fps, Firefox caps at 40fps. I will reach them now.

As it seems, everything is fine now :)

Thanks a lot Generix for spotting the issue in the build system, I completely forgot what I did here !!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.