Sample apps don't run

I installed Maxine on a Windows machine with a GeForce RTX 3090. I followed the instructions about installing the latest drivers, etc. When I run the sample apps (such as UpscalePipelineApp and BatchEffectApp) they produce no output and exit immediately with code -1073741515.

Any tips?

Note: I am running the provided run_local.bat, which executes the pre-compiled .exe files.

To be honest, I can’t say that I’ve ever encountered the error 1073741515. But I can assume that your files were damaged when installing Maxine, which is why the program simply does not work. Try updating or completely reinstalling the software. File system error 1073741515 translates as error type 0xC0000135. It describes the inability to run an executable program due to the lack of necessary components (one or more DLL files) or incorrectly configured system files.

Hi, thank you for the explanation! OK I will see what I can do. Currently trying to compile the apps myself rather than running the precompiled ones.

Note, I also got the same exit code -1073741515 on a different machine with different hardware/OS version/etc.

Update: I compiled the source myself according to the instructions in the GitHub README; those .exe files also produced the same exit code.

I am guessing that it can’t find the .dll files that are part of the Video Effects SDK. I even added C:\Program Files\NVIDIA Corporation\NVIDIA Video Effects to my PATH but that made no difference.

OK I finally got it to run! I added the samples/external/opencv/bin path to my PATH. Then the precompiled versions worked.

Another thing that confused me while compiling was that the README says:

  • For the source folder, ensure that the path ends in OSS.
  • For the build folder, ensure that the path ends in OSS/build.

but i could not find any folder called “OSS”, so I just created the ‘build’ folder in the root of the project, next to nvvfx/, resources/, samples/, etc.

1 Like

True, updates to Windows are already so tired, they constantly appear while only interfering. Congratulations to you chris85 that you were able to find a solution to your problem! I hope you won’t have any problems in the future!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.