Screen freezes when showing desktop grid as a mouseover notification is fading in with Nvidia drivers 396.54 on Plasma DE (KDE neon)

KDE neon is Ubuntu LTS (currently 16.04) with KDE’s Plasma desktop. The desktop has virtual work-spaces. The shortcut “Ctrl + F8” is assigned by default to show desktop grid.

If I can trigger “show desktop grid” while a mouse-over notification is fading in, the screen freezes. The issue is very easily reproducible this way.

Here’s a video explaining how to reproduce it. https://youtu.be/_l1ab_PLP7Y
nvidia-bug-report.log.gz (148 KB)

Could you confirm the compositor settings (“Rendering Backend”, “Tearing Prevention”)? Do you find that these settings influence the repro? I was not able to repro on KDE Plasma on Ubuntu 18.04 with the default settings.

Thank you for your reply. I will check and feed you back as soon as I can.

As a side note, KDE neon currently uses 16.04.

Hello! I have OpenGL 3.1 as the backend, and I have Tearing prevention set to Never.

Attached is a screenshot of the compositor settings.

Note that in the Nvidia X server Settings dialog I have “Force Full Composition Pipeline” enabled.

It’s not very easy to reproduce the bug. I have to exactly time the “fading in” animation of the notification with triggering “show desktop grid” (Ctrl+F8 by default). It takes me at least 3 trials to reproduce it.
Screenshot_20180908_122120.png

Bump! Any updates on this? I’m still experiencing the issue. It’s exactly as I’ve described it. It happens whenever I try showing the desktop grid as a notification is fading in. I can’t recover from the bug. When it happens I lose all my work.

Thanks. I was able to reproduce the freeze when using the OpenGL 3.1 backend. I am however not able to reproduce it with the OpenGL 2.0 backend. Could that be a work around for you while we investigate this issue?

Unfortunately I tried switching the backend to OpenGL 2.0 and I could reproduce the issue the same way as described. I did it twice to confirm.

Thanks for your feedback, we are tracking this internally as bug 2383719.

From the Desktop Effects page on the System Settings app, there is an extension called Present Windows under the Window Management heading near the bottom of the list. In the options dialogue for this extension there is a check box that says “Fill Gaps”. See the red circles on the two screen shots here: https://imgur.com/a/ZVmJwa7

Would you mind checking whether you have that option selected, and if so attempting to reproduce the issue with is disabled? From what I can tell that code is what’s causing the hang. The effect is pretty subtle, so maybe this can serve as a not-too-obtrusive work around at least temporarily.

Yes it was enabled. When I disabled it I could not reproduce the bug. Thank you so much!