SD-Card reader not working after flashing

Hi, I´m a totally newbie in the Jetson field. I flashed my Jetson Nano 4Gb emmc with the latest Jetpack. Everything´s working, but not the SD-Card reader. The SD card will be recognized from the Jetson while using a USB SD-card reader. But not from the built-in reader.
So, how can I solve this? Maybe there´s a driver missing or something?

Basically you are asking the same question as this post. Please follow this up.

Hi, nearly. But I don´t have a Devkit. My Nano has originally a SD slot.
The funny (sadly) thing is: I have flashed it a few days before, then I got the same issue. But I somehow solved this and I was able to read SD cards and also install the OS onto it. But yesterday I crashed the Nano and must flashed it again…and unfortunately I don´t know what I made how to solve this SD-slot issue.
I only know that this was only a few commands, without editing a file or something. Crazy…I know, but now I´m facing this issue again :(

Err… I am not sure if I understand your comment correctly.

If you are not using a devkit, then please ask the vendor who sold you the carrier board for the BSP you are using.

They shall provide the BSP which has sdcard driver enabled. This is not something we can help. As we don’t have the detail hardware info of their carrier board…

Also, I am not sure if you really have to use sdcard or not… There is internal emmc in your module if you are not using devkit module…
For that module, you can flash with sdkmanager and it can boot up too… But sdcard slot won’t work as sdkmanager is only for devkit case.

The brand is “youyeetoo”. Yes I have the internal storage, but it is too less. There´re only 4Gb left. So I wanted to boot from my 64GB SD.

You don’t need to. It is much easier to mount the SD card (/dev/mmcblk1 for the whole card, mmcblk1p# for the partitions) into an empty directory and use symbolic links from there. (ln -s …) Edit /etc/fstab in order to make the mount permanent.

This is basic Linux/Unix knowledge.

Sorry, I don´t get it. But how can I mount a device, when the device not even listed as a device?
I checked “sudo fdisk -l” and the 64gb card is not shown up.

ok. Thought it was just a boot problem, not a general one. If the card isn’t listed you can’t boot of course.

Have you tried a smaller card up to 32GB (SDHC)? 64GB means the card is a SDXC type.

I’ve also experienced compatibility issues especially with noname cards. You should stick with a reputable brand (Samsung, Sandisk, Kingston, Lexar, Toshiba) from a trustworthy source in order to avoid fakes.

The strange thing: it worked yesterday with exact the same card. but now i flashed the nano again and now i can´t manage to run it again.
so it can´t be the sd card (size, brand etc)

Hi @fchkjwlsq , @mkrlng

This is not regarding about what kind of sdcard in use.

@mkrlng 's board is a custom board. And by default our sdkmanager does not enable any driver for this kind of board.

In brief, no matter what kind of card inserted, there won’t be any /dev/mmcblk1 because the driver totally not enabled…
That was why I asked to check with board vendor because they should provide a customized BSP for this board…

Thanks again. I contacted the vendor and he sent me this link. Could you pls take a look on it? Maybe thats the solution?


Maybe. Please follow it and see if it can enable sdcard correctly on your side.

Please be aware that this is really case-by-case situation. We’ve helped many different sdcard cases on forum. But those we helped are all vendors. Not end users like you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.