SDK manager does not let me select Target Operating System

Hello,
I am stuck at step-1 of the SDK Manager where I am requesting

  • Product Category: Jetson (checked)
  • Host Machine: (checked)
  • Target Hardware: Jetson Nano dev kit (checked)
    But the “Target Operating System” box says: “Linux, not supported on linux”, and I cannot select any Jetpack version.
    I am running “sdkmanager_0.9.14-4961_amd64.deb” on a very generic Ubuntu 18.04 laptop with a core-I7 CPU.
    I have no clue as to what is going on.
    Thanks in advance for any insight into the problem !

Hi gilles.macherey,

Are you run sdkmanager on Ubuntu directly or via VM?

$ sudo apt install sdkmanager_0.9.14-4961_amd64.deb
$ sdkmanager
Login with Developer Zone username and password

Please reference install guide.

Hi Carolyuu,

Thanks for taking the time to reply.
I am running the SDK manager directly in Ubuntu, very straightforwardly, not via VM.
I am following the exact steps you reproduce in your code snippet, as per the install guide.
I have no problem logging, and get recognized with my user name and can access all boxes except the Target Operating System.
Still no joy…

Could you share a screenshot of “Linux, not supported on linux” error? We didn’t see such log before.

I have a similar problem. But I’m running the SDK from an Ubuntu 18 virtual machine (Virtualbox).

It is possible that the problem is insufficient rights of the user (with whom was the registration on the site) ?

Unfortunately sdkmanager is not working with vm environment. Could you find a native ubuntu host?

Is it possible to disable system check ? I want to use the SDK, only for compilation, I do not plan to use the ability to write firmware from a PC via USB. Compiling in a virtual machine is the only way to use powerful servers to work with sources (compilation). Using a powerful server or cluster and a virtual environment is a common practice to build from source for ARM.

Hi balbes-150,

I have a similar problem. But I’m running the SDK from an Ubuntu 18 virtual machine (Virtualbox).
I’m not sure if I understand your question. Can you please attach a screenshot and the ~/.nvsdkm/sdkm.log file?
Are you running on Ubuntu 18.04 Desktop edition or Ubuntu 18.04 Server edition? sdkmanager is only supported on Desktop edition.

Hi EdwardZhou

I will try to make a screenshot when I check the SDK Manager launch again. I am running Ubuntu 18.04 desktop in a virtual machine (in virtualbox). Earlier I was already answered that in the virtual machine SDK Manager does not work (need a host system with Ubuntu).

The problem of running the SDK in Virtualbox has been solved. I used the Ubuntu MATE version. To work, you need a strictly standard Ubuntu Desktop image. After replacing the system, everything began to work in Virtualbox. Downloaded and assembled all components. :)

Is this the solution?
Wouldn’t be better to use components in the manager that makes possible to install it any linux distribution? Or even better, make versions that can installed in other platform, like Windows and macs.

I have a standard ubuntu install, the version 20.04. apparently it’s not supported. Is there any other way to install jetpack?

2 Likes