SDK Manager gets download error with DRIVE Software 8.0 and 9.0

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
NVIDIA DRIVE™ Software 8.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.8.0.10363
1.6.1.8175
other

Host Machine Version
native Ubuntu 18.04
native Ubuntu 16.04
other

Hi,

I have a DRIVE AGX Xavier (PN: 940-63550-2000-100) that is still running the original software it was shipped with. I am looking to upgrade this to latest DRIVE OS 5.2.6. The release notes indicate I must upgrade step-by-step from previous releases. So 5.2.6. says it can upgrade from DRIVE Software 10.0. 10.0 says must upgrade from 9.0. 9.0 says must upgrade from 8.0. I believe this unit is running DRIVE Software 1.0 from below info:

Aurix console:

shell> version
Info: Executing cmd: version, argc: 0, args: 
SW Version: DRIVE-V5.0.10-E3550-EB-Aurix-With3LSS-ForHyperion-3.00.07
Compilation date: Jul 20 2018, 09:08:33
Command Executed

Tegra-B:

apex@pa-dev-drvagx-01-b:~$ cat /etc/nvidia/version-ubuntu-rootfs.txt 
5.0.10.3-12606092

apex@pa-dev-drvagx-01-b:~$ uname -a
Linux pa-dev-drvagx-01-b 4.9.80-rt61-tegra #1 SMP PREEMPT RT Tue Sep 4 11:02:44 PDT 2018 aarch64 aarch64 aarch64 GNU/Linux

apex@pa-dev-drvagx-01-b:~$ cat /etc/os-release 
NAME="Ubuntu"
VERSION="16.04.7 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.7 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

After a lot of reading through the forums, I found that I need the host device running native Ubuntu 16.04 and that SDK Manager must be version 1.6.1. Additionally to get SDK Manager to allow flashing older software versions, I must run SDK Manager like ‘sdkmanager --archivedversions’. After all this I’m able to select ‘DRIVE Software 8.0’ as a target OS. I accept agreement and choose to download and install later. This ends up failing showing a ‘download error’ on several packages. Similar occurs on Software 9.0. Tried on two different Ubuntu 16.04 hosts and same errors.

I tried accessing one of the failed URL on local browser and just get ‘file not found’ message. Seems like these older DRIVE versions are now missing some files.

Am I missing something to download either Software 8.0 or 9.0?
Or maybe different question is what is recommended steps to get this unit upgraded from DRIVE Software 1.0 to DRIVE OS 5.2.6?

Can I skip Software 8.0 & 9.0 and flash Software 10.0 from Ubuntu 18.04 host? Software 10.0 does download successfully on an Ubuntu 18.04 host. However the 10.0 release notes say you can only upgrade from DRIVE Software 9.0.

Lamar

Hi @lamar
I’ll check internally and update you. Thanks.

Thanks! I’ve attached a set of log files from SDK Manager when trying to download Software 8.0 & Software 9.0.

SDKM_logs_DRIVE_Software_8.0_Linux_for_DRIVE_AGX_Developer_Kit_2022-06-16_17-24-32.zip (88.9 KB)
SDKM_logs_DRIVE_Software_9.0_Linux_for_DRIVE_AGX_Developer_Kit_2022-06-16_17-01-10.zip (56.2 KB)

Is this from “sdkmanager --archivedversions” command?

Yes. I’m using the “sdkmanager --archivedversions” command as that is only method to see a Target OS option. Running as just “sdkmanager” then the Target Operating System box has nothing to select. It just says “Linux”, but clicking there does nothing.

$ sdkmanager --ver
1.6.1.8175

We are checking internally and will update you.

You should be able to use SDK Manager to install DRIVE OS 5.2.6 directly.
However, the most likely issue would be the Aurix FW may not auto-update correctly so that you would need to refer to Flashing AURIX to flash with memtool on windows host.

Important: In any case, do NOT click erase button to erase the UCB area. Once UCB is erased, the chip is dead.

I used the SDK Manager to install DRIVE OS 5.2.6. First on Tegra B and then on Tegra A. Both completed successfully. But when looking at Aurix FW I think that may have failed as it says “E3550-B03 with TLF35584 B/C-Step”. But I think it would show A-Step. Possibly it flashed the AURIX Step B FW instead of Step A? Can you confirm with output I’ve provided below?

I should have Aurix Step A as bottom of DRIVE AGX has “E3550: 699-63550-0001-500 C RW0”.

Aurix before flash:

shell> version
Info: Executing cmd: version, argc: 0, args:
SW Version: DRIVE-V5.0.10-E3550-EB-Aurix-With3LSS-ForHyperion-3.00.07
Compilation date: Jul 20 2018, 09:08:33
Command Executed
shell>

user@drive:/usr/bin$ nv_aurix_update -get_fw_version
Flashed EB fw version 3.00.07.00
SW Version: DRIVE-V5.0.10-E3550-EB-Aurix-With3LSS-ForHyperion-3.00.07

Aurix after flash:

Shell>version                           
                                        
DDPX Aurix Serial Console
E3550-B03
with TLF35584 B/C-Step
UPDATE SW Version  1.24
Shell>

user@tegra-ubuntu:/etc/systemd/scripts$ nv_aurix_update -get_fw_version
Flashed UPDATE fw version 0.00.00.00
SW Version: d���
AURIX Chip revision: 00

user@tegra-ubuntu:/etc/systemd/scripts$ sudo bash nv_aurix_check_fw.sh 
starting Aurix FW checking...
Checking arguments...
Checking Ping to AURIX 
Ping to Aurix successful
Flashed UPDATE FW version is 0.00.00.00
MCU does not have a valid UPDATE FW. Exit.....

Appreciate if you can confirm. I did already look at the steps you provided for Flashing AURIX. I tried the memtool on a Win10 host. However when I tried to connect to target it came back with “can’t connect to target”. If I use PuTTY to connect to COM18, then I’m able to access the console and the ‘version’ command returns what I showed above.

Which step did it fail in? Is it set to PRG position?

In the Flashing Aurix doc, it failed for Step #13 in the section Creating the MCU Configuration File. This is the initial click to connect to the target. The switch is in the PRG position. Tried another USB A-A cable. Tried after power cycle Drive agx. The memtool link downloaded v6.0 of the tool, where the doc says it’s 4.7. When creating the default target config it differs from the doc a little too. I have to go under `TriCore Aurix 2G’ to find the TC39x option. Maybe this config file is wrong for this older Drive AGX? Can I download memtool 4.7 still?

I was able to resolve the failed to connect issue. The solution was to first remove AC power from the Drive AGX. Then move switch to PRG position. Wait 30 seconds while power is off. Turn on AC power. Now memtool is able to connect and successfully program the Aurix firmware.

Here is all the version info I can find after flashing Aurix via the memtool command. Hopefully this completes the upgrade to DRIVE OS 5.2.6 on this system.

Aurix MCU console:

NvShell>version
Info: Executing cmd: version, argc: 0, args: 
DRIVE-V5.2.6-E3550-AFW-Aurix-With3LSS-StepA-4.04.01
Command Executed
NvShell>

Tegra-A shell:

apex@tegra-ubuntu:/etc/systemd/scripts$ nv_aurix_update -get_fw_version
Flashed AURIX fw version 4.04.01.00
SW Version: DRIVE-V5.2.6-E3550-AFW-Aurix-With3LSS-StepA-4.04.01
AURIX Chip revision: 00

apex@tegra-ubuntu:/etc/systemd/scripts$ sudo bash nv_aurix_check_fw.sh
[sudo] password for apex: 
starting Aurix FW checking...
Checking arguments...
Checking Ping to AURIX 
Ping to Aurix successful
Flashed UPDATE FW version is 1.29.16.00
Aurix Update : Main FW selected: AFW
Aurix Update : Alternate FW selected: EB
Rootfs FW version is 4.04.01.0, DRIVE-V5.2.6-E3550-AFW-Aurix-With3LSS-StepA-4.04.01
Response_From_Aurix
Flashed FW version is 4.04.01.00
SW Version:  DRIVE-V5.2.6-E3550-AFW-Aurix-With3LSS-StepA-4.04.01
Aurix is booted with Latest FW
Rootfs UPDATE FW version is 1.29.16.0
Flashed UPDATE FW version is 1.29.16.00
Aurix is flashed with Latest UPDATE FW

apex@tegra-ubuntu:/etc/systemd/scripts$ cat /etc/nvidia/version-ubuntu-rootfs.txt 
5.2.6.0-27062047

apex@tegra-ubuntu:/etc/systemd/scripts$ cat /etc/os-release 
NAME="Ubuntu"
VERSION="18.04.5 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.5 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

apex@tegra-ubuntu:/etc/systemd/scripts$ uname -a
Linux tegra-ubuntu 4.14.193-rt92-tegra #1 SMP PREEMPT RT Mon Apr 19 02:11:35 PDT 2021 aarch64 aarch64 aarch64 GNU/Linux

It looks good. Please submit another ticket if encounter other issues on 5.2.6. Thanks.