Serious regression in legacy 304xx-304.132 drivers

I’m on Manjaro Linux which is an Arch derivative. I’m on their Testing repo so I can help troubleshoot issues before they hit the stable repo. I own a Dell laptop with an Nvidia Go 7950GTX GPU. The latest legacy Nvidia-304.132 drivers introduce a regression that doesn’t allow X to start properly. I suspect it’s related to the GLX issues mentioned elsewhere in the forum because Manjaro enables compositing by default in all of its official builds.

The Manjaro developers have tried 5 revision releases of the driver and various kernel configurations using patches from other distributions. None of which have worked. X is unable to load. With the some, the kernel module gets loaded, but X crashes before starting the display manager, with others modprobe can’t find or load the kernel module.

I don’t know where to begin to give you a proper bug report, since they’re applying the above mentioned patches and I don’t know what’s being altered from the official driver release or in the kernel configuration to get them to install. I do know, however, after researching, that several major Distributions have withdrawn these drivers from their repos or are advising their users not to upgrade to them, Including Fedora, and Debian. Arch hasn’t released it at all, which is unusual since it’s cutting edge.

Please look into this matter. I know that support is ending soon for these GPUs, so it’s of utmost importance that we have properly working drivers for the latest kernels and Xorg server before such support is terminated. TIA