Setting primary display

Greetings,

I am using driver 346.35 on a 64 bit Linux on my Dell Precision M6800 Laptop. The card is a Quadro K3100M.

Apparently, my machine has an Intel card and the Nvidia. I got an additional monitor working. The NVidea sees only the second monitor. The normal Linux monitor control sees both.

I managed to get it to work but I have two problems, the first is: My machine sees the external/Nvidia monitor as primary. How can I change it so that my laptop screen is primary?

I tried xrandr but it gives an error if I try to set the laptop screen (eDP-1-0) as primary.

Thanks.

Blake

Until xserver 1.17, the X server doesn’t allow setting a RandR 1.4 provider output as the primary. Version 1.17 fixed that, though there’s still an update I need to make to the NVIDIA driver for that to work properly.

I too have a M6800, and you can disable the onboard (intel) entirely (in the bios setup, under tab “video”, disable the “enable switchable graphics” option). Then the Quadro directly drives all
outputs (including the panel), which works best in Linux.

Thank you!! Disabling the switchable graphics fixed ALL of my problems!! Thanks!!

Thanks, this helped me out a ton with my M4800 running xubuntu. Now I have a docked machine w/ both external monitors and the laptop screen enabled at once.

I can now undock without getting a blank screen. Re-docking doesn’t automatically re-enable the other screens but I can go into the system settings -> display menu and re-enable them easily.

Only problem left for me is that since choosing the proprietary nvidia driver in the ubuntu additional drivers menu and disabling switchable graphics the screen for unlocking my fully encrypted disk doesn’t work. The screen for entering the passphrase pops up but isn’t active or something. There’s a regular black and white cursor one line down from the top and when I type text shows up there unobfuscated and writes over the GUI background. Pressing enter does nothing. To boot I need to go into recovery mode with grub (where there is a text version of the disk unlock passphrase entry) then resume a normal boot.

edit: found a workaround for the disk encryption issue based on the information here https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/1375435

edit /etc/default/grub to include the line
GRUB_GFXPAYLOAD_LINUX=“640x480”
remove “splash” from GRUB_CMDLINE_LINUX_DEFAULT
then run
sudo update-grub

and reboot

this gives a text prompt for entering the disk encryption passphrase