Setting up Netplan on Jetpack 4.5.1 from command line


I am trying to setup an image for jetson with DHCP enabled, a couple of custom routes, and utilizing netplan from the command line only.

We need to desktop disabled and it seems the only information I have been able to find uses the desktop for configuration of the network. I am also noticing that the network-manager install and trying to enable networkd instead doesn’t seem to work correctly like other Ubuntu distro’s. I tried to install netplan and set the render to NetworkManager. Then I tried to switch the network stack to networkd and change the renderer in netplan to networkd. Both approaches leave the eth0 interface disabled. I am using Jetpack 4.5.1 for this and again, have to use Netplan.

Any suggestions on how to get this to work is appreciated.

Sorry for the late response, issue seemt not posted at right forum.
May other developers share experiences if they done something similar before.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.