SF3325 : Cannot connect to camera / cannot connect to camera server

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[-] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
[*] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[*] native Ubuntu 18.04

Hi everyone,

I have flashed my target board and now I was just exploring all the samples in order to see what this Nvidia Drive AGX is able to do.

But, when I launched samples who are using camera I got an error message.
Down below a picture of my error:

I dont know how to reset my Aurix, maybe that’s the problem.

Thanks for your help :)

1 Like

Hi @luciano.ojeda ,

Please see if Flashing AURIX on Xavier helps.

Hi @VickNV , how can I launch the Aurix console?
I dont have the shell command on my minicom so I can’t write any command :( I have the version 2.7.1 .

Please refer to Accessing the SoC from UART and use /dev/ttyUSB3 to access it. Thanks.

@VickNV I can’t do the step 6, it doesnt work …

Does your host system connect to USB 2.0 Debug port of the target system (same connection for flashing)?

1 Like

@VickNV Yes it is connect to the debug port.
Well, today it is working I don’t understand why and how but it works now

Well, I am back…

I restart the Nvidia Drive AGX, and now my camera is no more detected and It’s no more working …

I got the same error as yesterday … I don’t understand is it related to the power supply…?

And also when it was working It was only detected on TegraA.
Then I was exploring the drive IX samples on TegraB ( because it is not available on TegraA) and I was not able to connect with the camera server…

Does anyone have this problem to?

Please try to recall if you changed anything before not working again.

1 Like

I would suggest you to create another topic for this after solving the current topic.

Please also see if the following topics help.

The log doesn’t look you’re using DRIVE Software 10.0 (including DRIVE OS Please double confirm it. Thanks.

I am using Drive software 10.0

Thanks. Please check if those topics helps on your problem.