Unable to flash drive OS 5.2.6 on Drive AGX

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.7.1.8928
other

Host Machine Version
native Ubuntu 18.04
other

Flashing fails for Drive OS 5.2.6 with the below error:

info: NV_DRIVE_FLASH_DDPX_PARALLEL_COMP@DDPX: :[E]: QbCreateFSImagesExt                :  359: Error (Unknown) (0x8900)

I have tried flashing Drive OS 5.2.0 and Drive Software 10 and they too failed with the same error. While Aurix is accessible over minicom, I am not able to access Xavier A and Xavier B.
SDKM_logs_DRIVE_OS_5.2.6_SDK_Linux_for_DRIVE_AGX_Developer_Kit_2021-12-12_02-31-40.zip (475.4 KB)

Dear @himanshu.dongre,
May I know what is the DRIVE release installed on target currently?

The currently installed version is Drive OS 5.2.6. However, we tried to manually install TRT 8 binaries from jetson as the model we are working on cannot be converted on TRT 6.5.0 (current version on Drive AGX). That did not work out well and therefore we wanted to restore the default version.

Dear @himanshu.dongre,

While Aurix is accessible over minicom, I am not able to access Xavier A and Xavier B.

Check tegrareset on aurix console(DRIVE OS Linux).

Were you able to see anything on monitor if the target is connected to display? Could you check ssh access to it?

If possible, could you check flashing from another host? Also, make sure the target is not in recovery mode(lsusb on host should not list Nvidia Corp in the log) when flashing using sdkmanager.

Hi @SivaRamaKrishnaNV ,

I was able to establish ssh and minicom connection again with Xavier A and Xavier B using the tegrareset and tegrarecovery off commands from the reference provided by you. Before attempting the flash again I verified that lsusb on host does not show Nvidia Corp in the log. However, the flash still fails with the same error. PFA latest sdkm logs for your reference. I am currently using the Drive AGX remotely, so it is a bit difficult to check with an alternate Host PC.
SDKM_logs_DRIVE_OS_5.2.6_SDK_Linux_for_DRIVE_AGX_Developer_Kit_2021-12-14_21-18-03_latest.zip (492.5 KB)

Dear @himanshu.dongre,
just want to understand, if you can access DRIVE OS 5.2.6 Xavier A/B again after resetting tegra from terminal, why can not use the same DRIVE OS 5.2.6, do you see if your applications are failing on target?

Could you check flashing DRIVE OS 5.2.0 and see if it works?

Hi @SivaRamaKrishnaNV ,

Being able to access Xavier unblocks us for now. However, I would like to find a solution for this issue so that we can flash the hardware in future if required. As mentioned in the first post, I have already tried flashing Drive OS 5.2.0 and Drive Software 10 and it failed with the same error.

Dear @himanshu.dongre,
Thank you confirming that it is not a blocker currently. I will check internally on the flashing issue and update you.

Dear @himanshu.dongre,
Could you double check if the host machine has enough space needed to flash target. Please see system requirements at Getting Started: DRIVE OS 5.2.6 :: DRIVE Platform Installation Guide with NVIDIA SDK Manager

Dear @himanshu.dongre,
Could you provide any update for this issue?

Hi @SivaRamaKrishnaNV ,

Apologies for the delay. Yes, we made sure the Host machine has enough space. Also, I couldn’t find any space-related issue in the sdkm logs.

Dear @himanshu.dongre,
The error code in the log (0x89) indicates space related issue. May I know the available space on host?