Nvidia DRIVE OS failed installation

I try to flash Nvidia DRIVE OS into Nvidia pegasus.
However, install error occurs but i don’t know how to solve it.
This is my host pc
: Ubuntu 18.04 LTS

Dev system: Nvidia DRIVE pegasus

The error is
“flash: [exec_command]: /bin/bash -c /tmp/tmp_NV_DRIVE_FLASH_DDPX_PARALLEL_COMP.arc.sh; [error]:”

I attach some materials please helping me sir


And, this is the log
SDKM_logs_DRIVE_OS_5.2.6_SDK_Linux_for_DRIVE_AGX_Pegasus_XT_2024-02-05_19-26-33.zip (435.5 KB)

Dear @JaeJ,
Please see My Drive AGX Xavier is not working at Flashing process in sdkmanager helps? I notice same error in log.

I wonder what is the next step after command “sudo minicom -D /dev/ttyUSB2”
I attach results after above command

And, when i flash using docker, i face an error like this:
FlashTegraPDKInstaller faild, error 140!
If you know how to solve it, please tell me.

Dear @JaeJ,

  1. What is the current DRIVE release on target?

  2. Please verify the aurix port via minicom. Check connecting to /dev/ttyUSB3(default aurixport) if it works.

  3. If aurix port can be opened via minicom, check if you see additional NVIDIA device on host (run lsusb on host) when board is set to recovery mode. The board can be set to recovery mode by runningtegrarecovery on & tegrareset on aurix console.

  4. Make sure to keep the board in normal mode( run tegrarecovery off & tegrareset on aurix) and close all minicom connected sessions to target before attempt to flashing.

  1. Someone flash DRIVE OS but it doesn’t work well. So i try to flash(reflash) 5.2.6 DRIVE OS on target.
  2. “sudo minicom -D /dev/ttyUSB3” This command works!
  3. When i use “lsusb”, there are four “Future Technology Devices International” ports but there is no NVIDIA port. I think “Future Technology Devices International” ports are NVIDIA related ports
    AND, i wonder how to run tegrarecovery on & tegrareset on aurix console.
    Would you tell me how to do it? how to get into aurix console to execute aurix commands.

Bests

When i command “sudo minicom -D /dev/ttyUSB3”
There is no line to command.

ttyUSB3

Please try pressing the “enter” key to check if the “NvShell>” prompt appears.

I have tried “Enter” key but NvShell has never shown…

Please provide the complete log regarding the issue with docker flashing.

This is two related log when i execute docker image by “sudo docker run -it --privileged --net=host -v /home/nvidia/ nvcr.io/drive/driveos-sdk/drive-agx-xavier-linux-aarch64-sdk-build-x86:5.2.6.0

log_a550f461b719c0dd6043230ab672989e.txt (2.0 KB)
pdkinstaller.log (17.6 KB)

The error message was found in the log:

[2024-02-06 12:45:52,741 root ERROR pdk_bind.py 136 68] Could not fetch board revision. Re-try either by re-connecting board or make sure all serial port processes such as minicom are closed.

Here are some relevant topics that might provide insights into resolving this issue:

If you haven’t had previous experience in flashing the devkit, I recommend referring to Setting Up the E3550 Platform to set up the connections properly.

1 Like

I solved it thank you!

Great to hear that you’ve solved it. Sharing your solution will be valuable for other developers facing similar challenges.

Ok. In my case, i turn on the PRG(program) button instead RUN button.
It works well in my case.

I hope this experience to help developers :)

Best regards

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.