NVidia SDK Manager Not Flashing: Failed to bind partitions

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

I am having difficulty flashing software to my device. I am unsure why it is not able to bind partitions but the flash fails immediately. I was originally getting a blue screen but after restarting I am able to see my desktop on the target hardware. I am unable to SSH into the machine (fairly unsure how to do it), but frankly I could use some help confirming how to properly do this as there was confusing directions within ethernet connection and I feel unsure if I have managed connections properly (I have connected ethernet cable from my host computer to Ethernet dongle, which is connected to 10 GBE port 3|4).

Also I was trying to read what version of drive I currently had on my system but when I look within /home/nvidia/drive-t186ref-linux/ folder there is nothing within the folder for a system file there is only a samples folder.

pdkinstaller.log (19.5 KB)

Hi @gurmeet.sidhu1

I saw the message in your log file. Please make sure no processes occupy the serial port or just reboot your host system and then try to install again. Thanks.

Hey VickNV,

Thanks for getting back to me is there anyway I can verify Minicom or usage of serial ports. I restarted my machine and flash failed immediately. I did also see the following message so I want to know how I can verify if the machine is communicating properly:

flash: exec_command: [ -e /dev/ttyUSB3 ] || ( echo Failed to flash device: detected no board connected to host with USB cable. >&2 && false

Thanks, Gurmeet

Please refer to Setting Up the E3550 Platform. You should use the USB 2.0 debug port to connect to the Linux host system for the flash.

Hey VickNV,

I do have the USB 2.0 Cable connected to the debug port but it doesn’t seem to recognize.


Are you using USB 2.0 A to A cable? Could you compare and share ~/.nvsdkm directory for my analysis?

Hey Vick,

Attached is the contents of my nvsdkm directory. Let me get back to you on if the cable is indeed usb 2.0 A to A cable. I just used a cable I already had for my Nvidia Tx2 developer kit

nvsdkm.zip (1.1 MB)

saw the same message below you mentioned.

“Could not fetch board revision. Re-try either by re-connecting board or make sure all serial port processes such as minicom are closed.”

The developer on Issue Encountered: Summary: Flash Xavier A+B in parallel, could not start with generic installer rebooted his host system and solved it. Maybe you can try using another host quickly?

Hey Vick,

I tested on another host and I got the same error. I have also attached a lsusb terminal output to perhaps share what items are connected. Again I can’t confirm any serial activity. But it appears flash doesn’t work again. I am not seeing the same partition error and I have attached the nvsdkm contents to compare.

nvsdkm_host_2.zip (467.7 KB)

Let me know your thoughts, thanks!

Are you running sdkmanager on vmware virtual machine? It doesn’t support installation on a virtual machine.

Hey VickNV,

I was running on VMware Virtual Machine, I have tried it on a Linux Desktop and it flashed successfully. However I am no longer able to see the desktop when I plug in my hdmi cable to XA-1.

Note in the installation instructions it mentions to use TCU Mixer or Terminal Emulation with links but both links just lead to main documentation page with no reference of either.

So I am not able to get SSH and display enabled.


If using 5.2.6, you should refer to its document, e.g. Finalize DRIVE AGX System Setup (Linux). There are all the information; “Enable Display” section has the guidance and below are SSH related pages.

*Accessing the SoC from UART
*Terminal Emulation

The 2nd set of links works, thank you for your support VickNV I believe this issue is resolved.

I needed to use Minicom before using PuTTy to communicate with the box to download the necessary GUI tools to enable the HDMI

1 Like

Good to hear your progress.