Flash Xavier A+B option tab while flashing using sdkmanager does not come

NVIDIA DRIVE™ Software 10.0 (Linux)

Hi @swarn.rathour.uj ,

What did you mean “does not come”? Thanks.

In step 3 of sdkmanager, the above circled green tab shows flash option only. After completion drive agx does not boot up. Thanks.

May I know which SDK Manager version you are using? just double check. Did you flash DRIVE Software 10.0?
Have you ever installed it or any release successfully before?

I tried to flash Drive Software 10. I downloaded NVIDIA SDK Manager 1.6.

Did you mean you went through DRIVE Software 10.0 installation in SDK Manager 1.6 successfully? If yes, can you access Xavier A or B via UART?

SDK Manager 1.6 installantation was successful. However if i run uname -a command in drive agx terminal the flash date is sep 20, 2019. As per the drive agx installation guide it mentions that drive agx takes 10 minute to boot up after flashing, in my case i dont see the Auto-run of vibrante-setup scripts window in drive agx display.

Please check your current version with the command.

$ cat /etc/nvidia/version-ubuntu-rootfs.txt

Dear @swarn.rathour.uj,
The board has DRIVE SW 10.0 now. Does the board has different DRIVE SW version earlier? Is the board connected to internet while flashing?

No board was not connected to internet while flashing. I am not sure about earlier DRIVE SW version. While flashing I set password, however while check user setting I see different length of password. Can you send me some document for building own application.

Dear @swarn.rathour.uj,
It looks the board already has DRIVE SW 10.0. Do you want to reflash the target again with DRIVE SW 10.0? If so, please check Getting Started with DRIVE Software :: NVIDIA DRIVE AGX System Installation and Setup

Please connect both host and target to internet and make sure apt-get is working on host. If it does not work, please attach the sdkm(~/.nvsdkm/logs & ~/.nvsdkm/sdkm.log) flashing logs for investigation.

That’s kernel build time, not flash time.

It looks right and you can also access the system.

Because the flashing issue was clarified, please create another topic if any further question. Thanks.

Dear @swarn.rathour.uj,
We have fixed the sdkmanager GUI issue and it will be available in future release