Drive AGX unable to flash Drive OS 5.2.6

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Hi, I am unable to flash my Drive AGX with Drive OS 5.2.6 from the sdkmanager. Previously, it would get stuck at 99.88% flashing and would not progress, asking me if I wanted to skip this process because it was taking a long time. I restarted my sdkmanager but now it says /dev/ttyUSB3 is opened by another application. No minicom windows are open on my host PC though. I have tried uninstalling Drive OS 5.2.6 and then reinstalling it but it gives me the same issues where first the flashing gets stuck and then I can’t try again after stopping it because /dev/ttyUSB3 is opened by another application. Any suggestions?

Hi, @atseng
I assume you’re seeing “Could not fetch board revision. Re-try either by re-connecting board or make sure all serial port processes such as minicom are closed.” as in the below topic.
Please restart your host system and try again.

I don’t see that error. However, I restarted my host system and got the same issues. First, there was the message “Installation of ‘Flash Xavier A+B in parallel’ is taking longer than expected. Do you want to continue installing this package?”. After I clicked no and tried to flash it again, I got the /dev/ttyUSB3 error. Here is my output log for reference. (271.3 KB)

1 Like

Please try to click ‘yes’ to continue the flash. Thanks.

I have clicked yes before and there doesn’t appear to be any progress and then the message about taking longer than expected pops up again so it appears that the process seems to be stuck.

1 Like

Please try if flashing with docker containers helps.

Hi atseng,

Have you managed to get device flashed successfully?
Any result can be shared?


@atseng did you see any suspicious messages on the AURIX Console (via ttyUSB3)?

We have been unable to flash; The error messages seem to indicate that the minicom is running. However we do not see that to be the case.

I’m asking you to check ttyUSB3 and see if see “Thermal Alert Triggered” message with the issue (as the other topic).

yea we did see that message

I also have the same issue when trying to flash the target. After restart the host PC, the " /dev/ttyUSB3 error" disappeared, but the flashing progress stuck at 99%. I also noticed that there is an error about ttyUSB3, I guess it could be related with the issue.

@atseng @user3705 please try if flashing after power cycling the target system helps with this issue. Thanks.

Hi, @zeki.zhang please create another topic for your issue. Thanks.

@atseng @user3705 also may I know the version before flashing 5.2.6? Thanks.

Our issue turned out to be a HW issue; we have sent back the drive to the factory and they are able to reproduce it.

Got it. You were saying you already shipped the system back to us and we was able to reproduce it on our side too. Thanks.