Drive AGX target board is unable to flash Drive OS 5.2.6

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04
Hello, I failed to flash Drive OS 5.2.6 to my Drive AGX target board with SDKmanager. Firstly it pops up “/dev/ttyUSB3 is opened by another application”, hence I restart my host PC. After the reboot, the error disappears and the flashing starts up at the beginning, but eventually the progress would stuck at 99%. I also tried to flash host PC and target board with Drive OS 5.2.0, still have the same issue. The log file is enclosed in the (152.3 KB)
By checking the information available in SDK manger terminal I found there is an error information may related with the issue, which is high lighted below:

Meanwhile I checked the information about the port ttyUSB3 and got the following message:

A thermal error repeatedly reported.
Does anyone has any suggestion? Is it a hardware issue or a software bug?

Dear @zeki.zhang,
If the target is connected to any display monitor, please remove it and run aurixreset in aurix console before flashing the target. Let us know if it help to fix the issue.

Hi, I ran aurixreset in aurix console, I found the target still reported the same thermal alarm as before, then I tried to flash the target, same issue happened.

Hi, @zeki.zhang

May I know which version your target system had prior to trying to flash DRIVE OS 5.2.6?

Also, can you try to flash DRIVE OS 5.2.0? Do you encounter any problems?

We successfully flashed Drive OS 5.2.6 on target prior to the current incident. After installing gdm3, we started to install the new Driveworks 4.0 and got several dependency issues. So we decided to flash again and install Driveworks under cmdline. But now these phenomena (flash is stuck at 99.7% all the time) are never seen before, so we came for help.

Yes, we did. Same issue, no difference.

Seems someone has solution, can you tell me what does “Connect to /dev/ttyUSB3 into nvshell” mean here, is it the debug port?

It’s to access MCU Console.

Please try if the developer’s solution or flashing after guest os boot (mentioned in Reflash 99% , the sdkmange stucks - #19 by VickNV) will work.

1 Like

Reflash 99% , the sdkmange stucks - #20 by tonyb.zhao looks your issue was worked around.

Yeah, reflashing is successful after following the experience from @tonyb.zhao

1 Like