Drive AGX target board Drive OS 5.2.6 fails to flash at 99% progress

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
[V] DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[V] Linux

Hardware Platform
[V] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
[V] other ( )

Host Machine Version
[V] native Ubuntu 18.04

I tried re-flashing the target with Drive OS 5.2.6 and the flashing process gets stuck at 99%.
I logged in using putty,

sudo putty -serial /dev/ttyUSB2 -sercfg 115200,8,n,1,N

I saw no errors regarding heat.

The terminal at “SDK Manager” doesn’t show any error except that it times-out after long time of flashing.


tegrarecovery x2 on
tegrareset x2



in the putty console, return error that these commands are unknown.

Also attached is a putty log of all target boot up info:
putty_log.log (80.9 KB)

I tried unplugging the computer monitor from target, and also unplugging network cable, then rebooting, re-flashing. Didn’t help.

VickNV any ideas?

Dear @Sunny127,
Please check the aurix console log to see if it is related to "Thermal Alert Triggered " issue? Please see the discussion on Reflash 99% , the sdkmange stucks - #17 by VickNV

@SivaRamaKrishnaNV As I written in my post, “I saw no errors regarding heat.”. I also attached a log from putty, the log contains no heat issues. @Nick Please helppp 😩

Dear @Sunny127,
From the log, it appears that you have connecetd to Tegra A console and not Aurix. Please check connecting to aurix using sudo minicom -D /dev/ttyUSB3

I powercycled the target, then I did

sudo minicom -D /dev/ttyUSB3

then I typed in:

tegrarecovery x2 on
tegrareset x2

but the heat errors still started to flow in.

Here is a video.
tegra1.mkv (3.0 MB)

Ok , I found a solution.

If install flashing fails at 99%

sudo minicom -D /dev/ttyUSB3

Heat error messages will start to come.

Open a new terminal:

sudo putty -serial /dev/ttyUSB3 -sercfg 115200,8,n,1,N

Write some jibberish.

The error messages on the minicom will stop.

in minicom, write:

tegrarecovery x2 on

tegrareset x2

Close all putty and minicom terminals.

Then run sdkmanager and try flashing again.


Dear @Sunny127,
Glad to hear that the issue is resolved.

Note that, when you reboot the board, there is a some time gap before thermal alerts appears on the Aurix console. We need to put the board into recovery mode and reset before the thermal alert messages appears on the Aurix console.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.