Reflash 99% , the sdkmange stucks

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[Y] Linux

Hardware Platform
[Y] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[Y] native Ubuntu 18.04
other (439.0 KB)

we also find the NVshell output some info shows the thermal is high, but I feeled the wind from the fan is not high, even cool

Dear @tonyb.zhao,
I notice the flashing of DRIVE OS 5.2.6 is successful in the logs. Please confirm which version the board has ? Does it has any issue before flashing?

The board is AGX XAvier DevKit[E3550], and now I want to downgrade it from 5.2.6 to 5.2.0
After flashing the board with OS 5.2.6 sucessfully, I can connect it to the display to the target board, the display can show normally, but after I reboot the target , I cannot connect with display any more. Only way to access the board is using putty by usb line
and I feel it has some bugs on OS 5.2.6, when the display shows well, I tried the nvsipl_camera, it crashed, and I check the code, it is related to initailize the window, the crash log I remeber that it show something wrong with openGL. And if I remove the -d option the camera can capture the frame normally.
But now I think I need to recover the board firstly, thank you very much

We would like to double confirm this was observed with 5.2.6 instead of 5.2.0, right?
If yes, the information in your first post may need to be corrected. Thanks.

I am so sorry
Yes , Now the target board OS version is 5.2.6

Thanks for confirmation. I just corrected it for you.

1 Like

Thank you, sorry again

Dear @tonyb.zhao,
Is the issue fixed? Were you able to downgrade from DRIVE OS 5.2.6 to 5.2.0?

@tonyb.zhao according to ModeSetCrtc failed for mode index 0, it seems you solved this problem. May I know how you solved it? Thanks.

Yes, the solution is like below:
1st step: sudo pkill X (after excute this command the error will not show)
2st step: if no error , but the monitor still cannot show the image captured by camera , you can change your monitor, for my side , I changed the monitor as a 4K, then it works

@tonyb.zhao I was asking about flashing stuck at 99% and seeing “Thermal Alert Triggered” messages in aurix console. I presume you have no the issue anymore, right? How did you solve or work around it? Thanks.

Shut down the NVIDIA DRIVE


There is very short time no thermal warning. During this period, you need to do:

Connect to /dev/ttyUSB3 into nvshell

tegrarecovery x2 on

tegrareset x2

Then warning will disappear, and you can flash

1 Like

Did you see “Thermal Alert Triggered” when flashing stuck at 99% or booting after flashing was complete?

Per the known issue in DRIVE OS 5.2.6 Release Notes (PDF), it shouldn’t affect flashing.

Yes, acutally ,the purpose is to type two canmand on nvshell :
tegrarecovery x2 on
tegrareset x2

If the thermal warning exist, we cannot type the above comand esiliy

1 Like

Tony, thank you for the solution. It solved our flashing stuck at 99% problem too.