[SOLVED] vkCreateRayTracingPipelinesNV raise exception in nvoglv64.dll

Hi, I’ve been following the ray tracing tutorial here: https://developer.nvidia.com/rtx/raytracing/vkray
And I’ve just completed the HelloVulkan::raytrace function part.
I built the program successfully. When I run the program, it raises an exception from the m_device.createRayTracingPipelineNV() function call.

The error says:
Exception thrown at 0x00007FFA5EF8CD15 (nvoglv64.dll) in VkExample1.exe: 0xC0000005: Access violation reading location 0x0000000000000073.

The line that raises this error is in the following function in vulkan.hpp:
template
VULKAN_HPP_INLINE typename ResultValueType::type Device::createRayTracingPipelineNV( VULKAN_HPP_NAMESPACE::PipelineCache pipelineCache, const RayTracingPipelineCreateInfoNV & createInfo, Optional allocator, Dispatch const &d ) const

My Vulkan version is 1.2.131.2
Nvidia driver version is 442.19 (GeForce Game Ready Driver)
OS is Windows 10, version 1909, build 18363.657

Have anyone met this before? Please help me

For any one that meets this problem with the same tutorial:
I found a similar tutorial here: https://nvpro-samples.github.io/vk_raytracing_tutorial/
And it actually works
I think I did something wrong in the original tutorial

It turns out that I forgot to call updateRtDescriptorSet inside the resize function. Now everything works. The tutorial is great.