Standalone scene script with livestream

Hi, I’m trying to create a simple standalone Python script that loads a USD scene and is livestreamed so the scene is visible in the Omniverse native streaming app. The script I’m trying to run is attached. (4.3 KB)

It seems to try to load the scene and then throws this error at the end. I can still access the stream via the Omniverse Streaming Client after this error is thrown but the scene I’m trying to load does not appear. Below is a screenshot of the error I’m getting. I’m looking for suggestions on how to get this to work or if I’m going about this incorrectly. This is running on Isaac version 2022.2.1. Thanks!

Hi. Can you please share the full logfile?
Can you load this usd by running the then open that usd from streaming client?
Please also try a smaller scene instead to see if you get the same issue.

Hi Sheikh,

When I start livestreaming using ./ --allow-root and select the USD through the GUI it loads the hospital scene USD without issue. I changed the original script to try and load simple_room.usd and saw what looked like the same behavior as before. Attached is the full log from the simple_room attempt. Thank you.

livesteamlog.txt (66.1 KB)

Thanks for the logs.
I am able to reproduce this issue.
We will investigate.

1 Like

@michaela.buchanan Can you try enabling “omni.kit.scripting” in /apps/omni.isaac.sim.python.kit file line #212:

# Python Scripting Component
"omni.kit.scripting" = {}

Also try applying this patch.

Thanks Sheikh. I made both of the changes suggested to omni.isaac.sim.python.kit and unfortunately it seems I’m still getting the same error as before when I try to run


I think it should be:
and not

1 Like

Looks like it works now, thank you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.