Stuck on login loop after installing nvidia drivers on Ubuntu-16.04

I have tried installing the drivers through nvidia-current and through ppa repository and both get me stuck on login loop. If I try and install through the drivers autoinstall nothing appears, and in the software and updates the additional drivers folder is empty.

I have an MSI Modern 14 A10RAS, with an Intel Core I7-10510U and an NVidia MX330.

I have tried solutions like .Xauthority, prime-select nvidia, basically anything I could find on online forums and nothing seems to work.
The bug report I’m attaching is before I restart the pc and get stuck on the login loop, otherwise I don’t know how I’d send it.
nvidia-bug-report.log.gz (53.1 KB)

That won’t work with 16.04. The kernel doesn’t support your intel primary gpu. Please use a current distribution with a current kernel.

I need to use Ubuntu 16.04 because the simulator I’m using for my thesis runs on the ROS/Gazebo (ROS Kinetic and Gazebo 7) version that only works on Ubuntu 16.04.
Isn’t there any workaround to this?

ROS for 20.04:
Gazebo 11 supports 20.04:
If you really want to use Gazebo 7, rather use Ubuntu 18.04.