Successful install on OS 10.6.4?

I’ve installed and used the 3.0 driver/toolkit quite happily on OS X 10.6.3 on a MacBook Pro with a GeForce 9400M. Since then
I’ve upgraded to 10.6.4
As I’ve now gone and purchased a 400 series card to use in a Linux machine with CUDA, I wanted to upgrade to 3.1 so that
the Mac where I do my development has the same version as the Linux server.

As per the Getting Started Guide, I deleted /usr/local/cuda and then installed the 3.1 driver software. Software install
went ok and when I boot the machine, in Console I see:[23] The domain/default pair of (com.nvidia.CUDAPref, IgnoreStartupCompatibilityCheck) does not exist[23] CUDA software is compatible with GPU driver.[23] Starting CUDA Kernel Extension

However the toolkit install fails with “The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.”

Seems like a pretty generic message. Has anyone installed 3.1 successfully on OS X 10.6.4?

I was able to get 3.1 installed and working properly on my i7 MBP running OS X 10.6.4. The card in my laptop is the 330M. After installing the CUDA 3.1 drivers, toolkit, and SDK in that order (which aren’t complaining to me) I can compile the SDK examples without trouble. However, deviceQuery was saying there were no CUDA-enabled devices. Using to force the nvidia card to be used, everything seems to be working fine for me (for the time being).

It’s worth mentioning that the 3.1 install I tried yesterday didn’t work. Removing the old install and doing it again today seemed to work fine. Not sure if something had been updated in the interim.

The fix below has worked for iMacs with nvidia gpus, and sounds like your issue could be related (based on the startup errors):

sudo chmod g-w /System/Library/StartupItems/CUDA/*

sudo chmod g-w /System/Library/StartupItems/CUDA/

(from here:


thank you so much for the hint about gfx:
I was getting crazy and it finally worked.

Thank you!