Suffering on CUDA & Nvidia Driver Installation on Ubuntu 16.04.3

Hello

I recently work on installing CUDA and driver for my computing GPU Tesla K20c on my Ubuntu 16.04.3.
What I am planning to do is, use Intel integrated graphic card for displaying and my Tesla K20c for computing. However, no matter how do I install the driver, I always end up with “low graphics mode”.

What I have done:

  • disable nouveau
  • install CUDA 8.0, without installing opengl
  • add repository and install driver using “sudo apt-get install nvidia-375”

Can anybody help me out of this nightmare?
Thanks in advance.

From a clean OS install, follow the instructions in the linux install guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#abstract

Already from what you have posted, I can see that you did not follow those instructions in at least 1 way and possibly 2 ways.

It’s admittedly a long document. But if you haven’t read it and understood it first, you’re likely to get into trouble. My guess is you have effectively mixed runfile installer method with the package manager method, which is explicitly a no-no in that install guide. A whole section is dedicated to pointing out that that is a no-no.

So if you want to ignore printed instructions and do it your own way, I can’t help you. If you want to follow printed instructions, I should be able to help.

Now that your install is messed up, the process of recovering it to a reasonably good starting state is to either:

  1. reinstall the OS
  2. attempt to clean up your mistakes by completely reversing the process and backing out each thing you did, using the section “handle conflicting install methods” as your guide to how to undo the things you have done so far.

Once you’ve cleaned up the mess, start over and follow the instructions.

Thanks or your txbob. But actually I indeed followed the instructions from nvidia, exactly the one you provided. Cuz I tried different ways, but one of them succeeded.

Concerning to that linux install guide, i stuck after finishing 3.6. After rebooting, I got this low-graphics mode and sometimes even the mouse and keyboard are not working at all.

I am not sure whether “Use a specific GPU for rendering the display.” applies to my case (integrated graphic card). Maybe it worth to try

Note that the instruction to disable nouveau is only given in the runfile install section. There are no instructions to disable nouveau in the package manager install section (because the package manager will do this automatically. There is no step or instruction to disable nouveau.)

the option to install without installing opengl is only possible with the runfile installer. and it only applies to the runfile installer if you actually do the driver install from the runfile installer.

The above is a package manager method to install the driver. You’ve already pretty much indicated that you installed using the runfile installer method, and you in fact installed a driver using the runfile installer. Now you are saying you used a package manager method to install the driver, or another driver.

You are not supposed to mix package manager methods and runfile install methods. If you do so, which seems pretty evident to me, then you are not properly following the instructions. You may have followed them, but you did not follow them correctly.

sorry it’s my fault not explicitly describing what I have done in a clear order.
actually I did both methods.

but now I managed using:

  1. install Tesla driver from Nvidia web, without installing opengl lib
  2. disable nouveau and install cuda runfile(local) without samples

hey,
I am also pissed off by 16.04.3 and driver 384. no idea what exactly to be done
I have tried a couple of combinations of installations to get bumblebee to switch between nvidia and intel.
none of the seems to work:
I am using alienware 13 r3 kabylake with 1060 gtx.
I have it working fine in nvida-375 and 16.04.2 but as of now that too didnt works.


https://hemenkapadia.github.io/blog/2016/11/11/Ubuntu-with-Nvidia-CUDA-Bumblebee.html
https://github.com/andrewwakeling/alienware-13-r3-ubuntu-16.04