Support for installing newer version of Python

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Hello, i have had some issues regarding the installation of a newer version Python (mainly internet connection issues, apt not working at all). I am looking for support for my problem. I intend to install some packages of Python that need newer version than the one available on the system (3.6.9).

Thanks in advance!

Edit: I have also tried to build from source but i was unable to install any newer version of Python, due to some errors.

Dear @david.nevezi-strango,

Does that mean sudo apt-get update is not working as well?

Yes, let me put a screenshot of the output

I am unaware of the exact configuration of my department’s network but i can tell you that much that besides having a connection to connect to tegra, via SSH, there is also an ethernet cable that has a direct access to the internet (without company firewall, etc etc). Both of them are connected to the 10 Gb/s ports.

Dear @david.nevezi-strango,
Can you share ifconfig output? Is it a fresh installed target or you made few changes in the target lead to this network issue?

My network colleague has configured a static ip and gateway for one of the ports (its enp4s0). Here is a screenshot.

Dear @david.nevezi-strango,
Could you please check connection steps in “To enable network access” In ?

I have followed the steps. Indeed, i did not have followed those ones, however, after doing a reboot via CLI, sudo apt-get update, it still gives the same error. Doing ping, says unreachable host.

Dear @david.nevezi-strango,
I would expect to get IP at eth0 once you make the connections at by default.

If you are just looking to enable internet, is it possible to reflash the target and follow the connection steps?

I have checked ifconfig and indeed for eth0, nothing has changed. I will continue with flashing the Target Tegra and will follow the steps.
Will keep you informed once i have done all these steps

Dear @SivaRamaKrishnaNV,
After doing a flash, reconnecting the ethernet Cable, doing a sudo reboot, it says connect, network unreachable, upon sudo apt-get update, throws the same error, and for the port eth0, not much has changed.


also, seemingly, minicom has stated something about eth0.200 while trying to do the ping.

FYI, To be sure, i have also followed closely the following video: NVIDIA DRIVE AGX Developer Kit - How to set up (

Dear @david.nevezi-strango,
Do you see flashing is successful message on host when you flash?
Could you share ethernet connection pictures and attach the syslog file from target?
Also, does the board has working internet connection earlier? Do you see any physical damage?
You tried to enp4s0 interface due to some issue with eth0?

Yes, I do get flashing is successful. About the picture and the syslog i will come back to you since i have to get clearance for it. One colleague mentioned that back in june, 2023, it worked, although he also used a 10Gb/s port. enp4s0 is mainly used for SSH, no internet connection comes from it. I will try to use different HSD ports, and ethernet port on the dongle. I ll also try to get a new HSD cable

1 Like

Dear @SivaRamaKrishnaNV
I am attaching the syslog and a picture. Please check the last boot since the first time i had forgotten to plug in the internet (there are only 2 boot sequences logged). Regarding the photo, if you find it inadequate, please let me know. For the HSD adapter, i have utilized the Channel B ethernet port since the cable does not click in when plugging into Channel A

syslog.xavier.log (311.5 KB)

I have also managed to get another HSD cable but it made no difference.

Dear @david.nevezi-strango,
From boot logs it looks eth0 interface is up. Could you check page 12 and 13 in product brief documentation and share your observations about LEG lights. Also. Please check changing to another HSD ports.

Also, could you check if network manager is running or dead?

I think i have found the problem. There is no executable for Network manager (i have tried running nmcli -v and NetworkManager -V and upon getting “command not found”, i have looked for them utilizing the command sudo find / -type f -name nmcli or NetworkManager and got 0 results). I will come back with my observations as soon as possible.

Regarding the mechanical installation guide, i am unaware which one you mean. if you mean the physical guide that was given with the HDK, i have it until page 9. Nevertheless, i have another power cable for the adapter, i will change that as well.

Dear @david.nevezi-strango
Note that systemd-networkd is the network manager installed instead of NetworkManager.
Please check the status and if restarting it helps (sudo systemctl restart systemd-networkd)

It was typo. Please check page 12 and 13 in DRIVE AGX devkit product brief(Log in | NVIDIA Developer)