Not Able to Connect to a Wired Connection (Ethernet)

Here’s my following info:
Hardware Platform: [DRIVE AGX Xavier™ Developer Kit]
Software Version: [DRIVE Software 10]
Host Machine Version: [Ubuntu 18.04]
SDK Manager Version: []


I went and visited some other Nvidia forums to try and fix my network on the Drive AGX Xavier but nothing has worked thus far. I am trying to connect to a wired ethernet connection but every time I click “connect”, it does not work. I tried restarting Network Manager, I tried editing proxies, I tried changing .conf files like resolved.conf, and I made sure my connection was Manual. The main issue being with the Network Manager GUI not showing the Wired Connection settings above the “VPN” or “Network Proxy”. Is there some commands I can do from terminal to fix this or offer a different solution than attempting to fix the GUI? Does it matter that I flashed my AGX with the host-PC being on Wifi instead of ethernet(affecting AGX network settings in any way…)?

I have done a bunch of reboots, restarts, and even flashed my AGX a second time. Any help is greatly appreciated!

Brendan Sting

I would also like to add to this post that trying to install firefox results in the following:

sudo apt install firefox

Reading package lists...Done
Building dependency tree
Reading state information...Done
Pacakage firefox is not available, but is referred to by another package. 
This may mean that the package is missing, has been obsoleted, or
is only available from another source.

E: Package `firefox` has no installation candidate

At first, I thought my sources.list was wrong. But I believe after some experimenting that my network is just not working. Thus why I am asking for help in the above post topic. Again, please provide any insight. Thank you.

Brendan Sting

Hi @stin7931,

Please check below materials. After DRIVE Software 10.0 installation, you should just need to make sure correct HSD connection.

Hello @VickNV,

I was following the guide “Setting Up Networking on the Host and Target” and I tried running this command for a networking step: sudo /etc/init.d/networking restart . However, this command resulted in a “failed” output on our host-PC. The terminal says it exited with error code for some odd reason. Any tips on solving this error? I added the lines the guide asked me to add in regards to the interfaces file. Please get back to me when possible, thanks!

Brendan Sting

Please let us know how you connect Ethernet cable to your target system.
On my side, it will just work after completing DRIVE Software 10.0 installation.

Hello @VickNV,

I will provide pictures below on how I setup my ethernet to my target system.

Hope this helps in your assessment of the problem. Thank you!

Brendan Sting

Your connection looks same as mine.
I met an Ethernet issue once and fixed it by changing my DHCP IP range from 192.168.0.x to 192.168.2.x.
What’s your DHCP IP range? ,

Please reflash your target system with SDK Manager. If it still doesn’t work without any manual steps, please share ifconfig output for our investiation. Thanks!

Got it! I’m reflashing my target AGX system now using SDK manager. I’ll get back to you shortly.


I still got the error from running the restart networking command for configuring the private LAN from host PC to Target system. I will attach my interfaces file and error log in a picture here:

Also, here’s the log of the ifconfig output on the target that you wanted:

Why do you need to run restart networking command? It shouldn’t need any manual steps.
In my case, after flashing, I can just plug in Ethernet cable to target system (just as host system) and it will be all good.

Well, in the guide you posted (the 3 links), it said to restart the networking and then do a hard reboot all on the host-PC. The page I am referring to is the Private LAN section of this web page: .

Should I skip this step then?

That’s kind of advanced steps.

my target system always has Ethernet cable (as host system) plugged. After flash completes, it’ll just works.

That’s odd. I usually have to manually setup my ethernet after each flash. When I do a ping I get 100% packet loss indicating my internet is not working. Which channel do you have your ethernet plugged into? Channel A or Channel B on the dongle?

Either one should work.