Cannot connect to internet through a router

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Right after I upgraded to Drive OS 5.2.6, my AGX cannot connect to Internet anymore, It use a HSD dongle connected to the 1GB/100MB 1/2 port.

When I check the NetworkManager.service:
sudo systemctl status NetworkManager.service

  • Loaded: masked (/dev/null; bad)
  • Active: inactive (dead)

I tried set ip manually, and it didn’t work:

  1. IP: sudo ifconfig eth0 xx.xx.xx.xx netmask
  2. ROUTE:sudo route add default gw yy.yy.yy.yy eth0 where yy.yy.yy.yy is gateway ip address
  3. DNS: Adding nameserver IP addresses to /run/systemd/resolve/resolv.conf and /etc/resolv.conf

Please Note, I connect my AGX to a router instead of Host pc.

Dear @Kang.JI,
Is the same connection setup working earlier? Could you share the network connection pictures for understanding.

Hi @Kang.JI,

May I know the status showed in E3579 LED INDICATORS (below from DRIVE AGX Developer Kit Product Brief (PDF))?

Thank you for the fast reply.
Yes, the same connection works fine on Drive Software 10.0.

Thanks Vick. I’ve attached two photos on the LED indicators below

My system works well on 5.2.6. I have no idea why it’s red.
Please try if rebooting or removing the router will help.

systemd-networkd is the network manager installed instead of NetworkManager.

Here is some updates. I solved the problem.

The root cause is that after update to OS 5.2.6, the original 100Mbe router is no longer compatible somehow. I added a 1Gbe gateway between them, bingo, problem gone, the DHCP on target eth0 works again.

Just to clarify, the orange LED indicates that its 100Mbe connection; when it turned green, meaning its full 1Gbe connection. On my picture, every LEDs indicate it’s working fine. There is really not any indication of error.

Good to hear that you solved the issue.