The problem of connecting to the internet via ethernet cable

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
[*] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[*] native Ubuntu 18.04

(The nvidia we use is the Nvidia DRIVE AGX kit)

hello, for connecting the internet, we plugged our laptop connected wifi to the channel-B of the nvidia ethernet connector via an ethernet cable ,and we connected the nvidia ethernet connector to the 10GbE 1 of the Nvidia box. It worked before, but it doesn’t work anymore and the led light of the ethernet connector is always in red/orange,how could we resolve this problem?

For the indicators, please refer to the image from DRIVE AGX Xavier / Pegasus XT Developer Kit Product Brief.

Thank you so much.

Based on your image, I think that we did right, but why Nvidia cannot connect to the internet by my laptop with wifi via ethernet cable? Could you tell me some possible problem of this issue?

Is it not working on Xavier A/B? What changes were made to the devkit before the networking issue occurred? Also, can you confirm the version of DRIVE OS currently installed on the devkit?

No, it didn’t work.
I followed the instruction in “To enable network access”, but xavierA has no internet like always, so I am confused about how the connector works.

And also, I am not the person who is in charge of the Nvidia from the beginning, so I do not know that how can I find my drive os version .Because I tried some linux command but it always told me that"No such file or directory"

Please run the command on the devkit to get its current DRIVE OS version.

$ cat /etc/nvidia/version-ubuntu-rootfs.txt

I would recommend that you sync up with the colleague who is familiar with the devkit.

Yes, I saw this answer in another user’s question and I tried, the response is "No such file or directory".

And you are right, I will try to contact with my ex-coworker for details.Thank you so much.


I have found my DRIVE OS version which is - 16902563.
Can you help me for the internet disconnection issue? thank you

As suggested earlier, please reflash DRIVE OS 5.2.6 first.

Thank you for your reply again.

But my concerned is, if I do the flashing, is here any risks for losing data in XavierB? Because you just told me that it will not affact the XavierA but I do not know the effect for B.

Dear @jieming.xu,
while trying to flash the board, you are expected to see pop up window where you can choose Flash A or Flash B or Flash A+B. You can choose Tegra A or Tegra B if you don’t want to flash both

Thank you for your reply.

Because I just want to flash the XavierB now, so my question is that if I do the flash on XavierB, is there any risks for B?

Dear @jieming.xu,
You won’t loose any data on Xavier A if you flash Xavier B.

In fact, we do not use the xavierA and our concern is the data in XavierB…so the data in XavierB will not be effected, too?

Dear @jieming.xu,
If you flash Xavier B, you will loose data on Xavier B. You may take a back of the data and check flashing.

How can I take a back of the data in the XavierB, because I have always the black screen in the XavierB

Dear @jieming.xu,
You can access Tegra A with from Tegra B and access Tegra B with from Tegra A. Please check it and confirm