Ethernet connection for Drive Agx

Hello,

I want to connect Drive Agx XavierA to Internet but there is nothing under network list(version:Drive Software 9.0 Linux)

Following HARDWARE QUICK START GUIDE https://developer.nvidia.com/drive/documentation, I connected the Dual GbE Dongle to the Black 1&2 1 Gbps 802.3bp Ethernet Port for internet access but I still got nothing. The dongle is blinking so I suppose that the hardware should be working.

Could you give me some advice? Thank you.

Dear dong.liang,

Could you please run “sudo /etc/init.d/networking restart” or reboot the DriveAGX?
And please let me know the network info using ifconfig -a command. Thanks.

Please also check your DHCP server to ensure this device is enabled with an IP from the server.

Fabian

Do not connect to 1&2. it should be connected to 3&4 on my case.

Hi Dong,

May I assume the issue got resolved yet?

Fabian

I also have encountered the same problem. My Driver AGX Xavier cannot connect internet.
I have run “sudo /etc/init.d/networking restart”,but it is useless.
Even reboot device,but it’s still useless.

Please exactly specify how you connected the AGX to the internet.

Thanks.

Fabian

Hi FabianWeise

I used network cable connect to 10GbE 1 port,but it cannot connect internet.
The current version is Drive Software 9.0 Linux. it can connect internet when I flash the device to Drive Software 8.0 Linux.
I don’t know why.
Thanks.

Hi,

I see your problem; you connected the AGX via the wrong interface.

DRIVE 9.0 comes as Hyperion Kit configuration, so the 10GbE ports 1 and 2 on the back panel are set to static. You can verify that under /etc/systemd/network/ as there all configuration files for the network are stored.

Originally, when building the target image, the network files are taken from /DriveSDK/drive-t186ref-linux/targetfs/<...>.

The conclusion is: Connect via the front panel via 1GbE or 100MbE; and else feel free to modify your network files under /etc/systemd/network to your needs as we do not restrict you from using the interface you want to connect to the internet, including the 10GbE ports on the back panel.

Fabian

I got all the connections right, the ethernet is connected to the Dual GbE Dongle to the Black 1&2 and I tried everything stated in the comments above in the terminal but still no connection.

Hi jolton94,

May I know which platform you’re using? Could you file a new topic with the problem?
Also, could you update you registration information with with private company/research email.

Thanks

Connecting to port 3&4 works for me. Seems like that’s connected to Xavier B though.

Hi all

The issue has been solved。For the Drive Software 9.0. connecting network cable to 10GBE 3/4 interface on the front panel user can use internet.

Thanks.

Hi qiaoyu.zhang and kmyang,

Good to know issues resolved at you side, thanks.