No IP address available on AGX

I am trying to connect the AGX(Pegasus) to the internet using a router.

But I don’t see it taking any IP address.

I even tried connecting to the Host machine using the adapter provided but I don’t see the IP address getting changed in eth.

Any networking changes do we need to change or set?

Dear puneeth.joseph,
Could you check for “Setting Up Networking on the Host and Target” Section your topic in Drive OS documentation.(NVIDIA_DRIVE_SW_8.0_References/DRIVE_Software/index.html#page/DRIVE%2520Linux%2520Software%2520SDK%2520Development%2520Guide%2FNetwork%2520Setup%2Fnetwork_setup.html%23)

Siva, I did read the document and the part Setting Up Networking on the Host and Target (Optional)[b][/b].

But I don’t find which network interface the host pc is getting detected. As connecting the host or not connecting the ifconfig retrieves same result.

Dear puneeth.joseph,
Can you please attach a picture to show your Host and board connection, ifconfig output in detail to understand the issue in better way. I assume you have flashed board with Drive 8.0.
Just for clarification, when you connect your board to internet via 10Gbe port, you notice change in br0 value. Please check that.

I have been using Drive5.X as I don’t have access to Drive 8.0.

Is there a major change, what I see with br0 is that it is static and set to always

Dear puneeth.joseph,
The last Drive release(Drive 8.0) for Drive AGX platform has Drive OS 5.0.13. You can check the below command to know the verison

cat /etc/nvidia/version-nv-pdk.txt

Please disconnect the internet cable, reboot the machine and check br0 value. You will notice it is assigned.

Hi Siva,

I flashed Pegasus with latest Drive OS 5.1.0 and am able to see the network interfaces.
Thanks for the support.

I also suffer this issue then try to can use network interface by 100MB port in the rightest side in front view of Pegasus. it should be workaround for me so far, upset.

BTW could you teach me how to flash Pegasus by SDK? Thanks!


I cannot flash my Pegasus via SDK or…

Dear Gary,

Could you please refer to below link and doc to flash DriveAGX?

DRIVE AGX Flashing Issues and Resolutions Technical Bulletin (03/19/19)

If you can flash the board via SDK manager, please attach a log of what you can not do. Thanks.