Surface Gripper Not Working

I’m currently trying to add a Surface gripper to a mobile robot through omnigraph. The problem is that it doesn’t react at all when I give execution inputs to the “Open” and “Close” inputs, and when I try to close the gripper manually it only changes the state to closed half the time.

The offending segment of the omnigraph is below
Screenshot from 2023-08-30 16-37-16

The execution lines just come from a “On Playback Tic” node. I’ve verified that all of the values and execution lines update correctly except for the “Surface Gripper” node, which is what doesn’t work.

Hopefully the video below illustrates what’s happening when I try to set the state manually.

Any help is appreciated.

Ok y’all! This ones a doozy. It turns out that if a Surface Gripper node in Omnigraph faults or returns an error for any reason, it will no longer work for the rest of time.

The whole setup I have works and worked when I initially set it up. The problem was when it faulted during a test I was running (some PhysX error, I think it tried to grab itself by accident). After that error, the Surface Gripper node stopped working altogether, even after restarting the simulation, reopening the scene, restarting Isaac, and restarting my computer. The way I fixed it was by deleting the node and setting it up the same way again.

Don’t know if this is a bug but that’s how I got around it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.