TAO -help cannot import name 'Iterable' error

Please provide the following information when requesting support.

• Hardware (T4/V100/Xavier/Nano/etc)
Windows 10 x64 with wsl2 ubuntu 22.04
• Network Type (Detectnet_v2/Faster_rcnn/Yolo_v4/LPRnet/Mask_rcnn/Classification/etc)
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here)
• Training spec file(If have, please share here)
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)


I am getting this error when I run TAO:

ImportError: cannot import name ‘Iterable’ from ‘collections’ (/usr/lib/python3.10/collections/init.py)

I searched the forum and someone solved it just installing Python 3.6, but I followed the tutorial and I am already in a miniconda environment with Python 3.6 (I used conda create -n launcher python=3.6):

python --version
Python 3.6.13 :: Anaconda, Inc.

Something else that I can try?

Thank you in advance!

Ok, I think that I’m clearing my mind:

I have this configuration:

Windows 10 + Docker desktop
WSL2 with Ubuntu 20.04
An Nvidia docker Image with TAO 5.0.0-tf2.11.0
Jupyter Notebook examples

I was trying to run the Jupyter Notebook and the TAO Toolkit service inside the docker image instead of trying to run it on the Ubuntu 's WSL image. Now it is working properly.

Glad to know the info.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.