Tensorflow 2.7 and Jetpack 4.6.1

Were you able to reproduce it on JP4.6.1 with your build_tensorflow.sh and tf2.7?

I am pretty sure I ran into the same error, that’s why I checked the TF source code and found the copysign was added in TF 2.5 onwards.

Last I tried, I also ran into issues with python3.6 due to a conflict between python3.6 and python3.6m with python3.6-dev package (header files are only in /usr/include/python3.6m). In the end I had to use python3.8. When you try it, please confirm if you see the same issue with python3.6?

Hi,

We have built TensorFlow 2.7 on JetPack 4.6.1 successfully.

It looks like this error is related to running out of memory on Jetson.
Our internal team recommends that you can reduce the number of build threads by passing the -j NUM_THREADS to bazel build.

Thanks.

What python were you using? 3.6, 3.6m or 3.8?

Hi,

We build it with the default python version.
On JetPack 4.6.1, it is python 3.6.

Thanks.

Thanks for finding out that I should use TF 2.7 for JP 4.6.1. It seems all those additional issues were caused by TF 2.8. Since TF2.7 compiles with your other patch, we can close this thread.

Though TF2.7 builds fine for me with python3.6, but when I pip install it, it gives error:

ERROR: Could not find a version that satisfies the requirement tensorflow-io-gcs-filesystem>=0.21.0 (from tensorflow) (from versions: none)
ERROR: No matching distribution found for tensorflow-io-gcs-filesystem>=0.21.0

Based on tensorflow-io-gcs-filesystem · PyPI , tensorflow-io-gcs-filesystem
Requires: Python >=3.7, <3.11
`

I checked with Tensorflow team and here is what I got

  • Python 3.6 had End of Life of Dec’2021. So its no longer supported by TensorFlow. TF 2.6 is the last version with Python 3.6 support. TF 2.7 & 2.8 support Python 3.7-3.10.

Hi,

Unfortunately, TensorFlow is a third-party library rather than ours.
You will need to check with the team to solve the compatibility issue.

If possible, it’s still recommended to upgrade to JetPack 5.0 for a better experience.

Thanks.

It is unfortunate JP 5 DP doesn’t support custom boards so far. We will have to wait until JP 5 GA.