Tensorflow Installation failed

Hi everyone.
I tried installing tensorflow according to these instructions: https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html
but unfortunately i did not succeed.
Here are the errors i got. I hope you can give me advice
dmesg.txt (79.1 KB) edid.txt (784 Bytes)

Hi,

It looks that there is a typo in Screenshot from 2020-08-31 20-51-07 image.
It should be python3 rather than pthon3.

Thanks.

Thanks for the answer. I know thats obviously a typo, but that’s not the problem. Do you know what all those red text is?
Here you can see, that tensorflow installation did not work.

Hi,

Have you setup the prerequisites library before installing the TensorFlow pacakge?
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html#prereqs

We can install the TensorFlow on JetPack4.4 GA without issue.
Thanks.

Hi.
I did all off that, but the process is always stuck with “building wheel for grpcio”. This goes on for over an hour and than it tells me grpcio failed. I also tried installing it with “sudo pip3 install grpcio” but this causes the same problem and does not work.

Hope you can help me.
Daniel

hi, daniel!
see this bug in https://github.com/grpc/grpc/issues/24028
you should downgrad setuptools.

Hi, To what version and how?
I started installing Tensorflow a few days ago and always got the error. I
assume I need to role back to 49.6.0 and it might work?
My colleague did not have the issue but he must have done it prior to the v50.0.0 update. It so damn close
in time between him and me. I really hope this is the issue.

Hi @magnus.gabell, please see this post for the versions to downgrade to:

https://forums.developer.nvidia.com/t/unable-to-install-tensorflow-in-jetson-nano/81289/9?u=dusty_nv

If you continue to have issues, you may want to try using the l4t-tensorflow container image.

1 Like

This did the trick. Downgrade setuptools to 49.6.0 and run the tensorflow 1.15.2.
Thank you for the support!