Tesla C2050 not working on Windows 7 enterprise


I have a Supermicro X8DTG-QF system with AMI Bios Ver.2.0a. The following are some of its specs:

  1. 2 Intel Xeon X5650 Processors
  2. 12GB of RAM @ 1333MHZ
  3. 4 HDD of 500GB each configured as RAID 0

I am using the on board VGA of the Supermicro motherboard (Matrox G200eW Graphics), as in pretty soon will be adding 3 more C2050 cards to the machine, thus a total of 4 C2050 cards.

I have installed the latest drivers from NVIDIA (263.06) and also SDK 3.2. I presently have a single Tesla C2050 installed.

Whenever I run the bandwidthTest or deviceQuery programs, I get an error message saying that no CUDA capable devices have been detected.

Am not sure why this happens, because I thought that TCC mode was default on the new NVIDIA drivers (V. 236.06).

Any suggestions?

In case this problem is due to the on board VGA, are there ways around the same? Will moving to Windows 64-bit Professional help?

TCC is disabled for C2050 w/ V263.06 by default. You need to enable it if you want TCC.

I tried to enable TCC using:

nvidia-smi -g 0 -dm 1

but got an error : allocateGpuResources() FAILED.

Any suggestions?

Also anyone who had similar problems, can you share the fixes that got you working?


Replying myself got it to work.

Had to edit the registry for it to work.

Followed the instructions on another post here: http://forums.nvidia.com/index.php?showtopic=181864

Wish NVIDIA would place these instructions in a sort of document or something similar that was easily accessible considering that many people would be building / adding cards to their existing machines.

But anyhow thanks for the help that I received on this post.