The command "xrandr" can not show the real connected monitor info in jetpack 4.5-4.6

I have tried many experiments, and when installing version 5.0+(Ubuntu 20.04) of Jetpack, it can display the correct connected display information. However, when I installing version 4.0+(Ubuntu 18.04), it cannot display all the connected display information. Whether my HDMI or DP are connected or not, the information displayed by the xrandr command is shown in the following figure:

May I ask, is this due to operating system issues? Is there a solution?

Is it still a configuration issue and how can we solve it?

Are you sure you have a physical monitor connected there? For example, if it is really working with our driver, xrandr will show either “DP-0” or “HDMI-0”. But that does not appear in your xrandr. It is more like there is a fixed value got hacked in your xorg setting.

I am very certain that the monitor has been connected. With the same operation, Jetpack 5.0+can display information similar to “DP-0” or “HDMI-0”. If my configuration is incorrect, can you provide me with some information for comparison and debugging?

Please share me the dmesg and /var/log/Xorg.0.log result. Attach the file here.
Please do not just copy and paste.

Xorg.0.log (12.1 KB)

The xorg log says it cannot get EDID from your monitor. Are you using NV devkit or some custom board?

The whole log looks weird. How many monitors are connected on your board?

Custom board, but since I installed JetPack 5.0+, it can now display “DP-0” and “HDMI-0”. How should this be explained?
Currently there is one, but even two are connected, and the ‘xrand’ command yields the same result

So are you going to share the dmesg or not …?

Also, could you just try jp4.6.3? We don’t really debug some old release like jp4.5.

how to share dmesg ?

I’ve try the version 4.6.3,it shows the same result

dmesg > log.txt

And then share that log.txt here…

Also one question here

Is your monitor able to show the desktop gui?

All functions of my monitor and Jetson are functioning properly

log.txt (101.9 KB)

Could you share what you saw in your desktop gui → system setting → display? Does it give you the correct resolution?

Take a photo and share it here.

Could you open a terminal in this GUI desktop and share me the xrandr result instead of using ssh terminal?

I don’t understand why the ssh terminal and the gui desktop is not the same result…

So looks like xrandr issue cannot reproduce if you use terminal on the GUI.