The "drivers for Jetson Nano" download is still corrupted

I get this error from the SDK manager:

Snarky,

Does this thread help?
https://devtalk.nvidia.com/default/topic/1056381/jetson-agx-xavier/jetpack-4-2-xavier-install-failed/post/5355914/#5355914

Hi snarky,

Please refer to below thread if can help:
https://devtalk.nvidia.com/default/topic/1056381/jetson-agx-xavier/jetpack-4-2-xavier-install-failed/post/5355914/#5355914

We’re investigating the cause now.

Thanks

Oh, exciting! I shall try with a different bzip version.

never change :D

Woof.

I am running into this issue as well - I have built a few new versions of Bzip2 ( master and 1.0.7 ) on Ubuntu 18.04 - however, it doesn’t fix the issue.

I tried the work-around with the LD_LIBRARY_PATH and PATH overrides, and that didn’t work.
What did work was installing the older bzip2 executable and libbz2-1.0 library system-wide.

On the host:

[code]sudo apt install bzip2=1.0.6-8.1 libbz2-1.0=1.0.6-8.1

[/quote]

Then start sdkmanager, and it worked for me.

seems Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2 are corrupted only decompressed Linux_for_Tegra/some files and error stop in nvidia_drivers.tbz2

tar xvf Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2 
Linux_for_Tegra/
Linux_for_Tegra/p3448-0000.conf.common
Linux_for_Tegra/nv_tegra/
Linux_for_Tegra/nv_tegra/LICENSE.weston
Linux_for_Tegra/nv_tegra/nvidia_drivers.tbz2
bzip2: Data integrity error when decompressing.
	Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

No, the files aren’t corrupted; they are just incompatible with the patched bzip2 executable.
If you downgrade bzip2 to the version I suggested in the above post, then this will work.
Unfortunately, this means running theoretically vulnerable software on your host, so you’ll probably want to re-update to the latest version again after you’ve unpacked/used the jetpack files.