Jetpack 4.2 Xavier Install Failed

10:27:20 ERROR : Drivers for Jetson AGX : command terminated with error
10:27:20 ERROR : install 'Drivers for Jetson AGX' failure, command < cd '/home/shreyas/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888' ; '/opt/nvidia/sdkmanager/resources/app/output/installUtils/adapter' -a='install' -c='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' -i='NV_L4T_DRIVERS_XAVIER_COMP' -v='32.1' -l='/home/shreyas/nvidia/nvidia_sdk/JetPack_4.2_Linux_P2888' -L='/home/shreyas/.nvsdkm/logs/JetPack_4.2_Linux' -p='15411' -t='P2888' -e='/home/shreyas/Downloads/nvidia/sdkm_downloads/Jetson_Linux_R32.1.0_aarch64.tbz2' > terminated with error

Looks like Jetson_Linux_R32.1.0_aarch64.tbz2 has a checksum error.

When I try

bzip2 --test Jetson_Linux_R32.1.0_aarch64.tbz2

I get the following:

bzip2: Jetson_Linux_R32.1.0_aarch64.tbz2: data integrity (CRC) error in data

The same goes for

bzip2 --test Tegra_Multimedia_API_R32.1.0_aarch64.tbz2

But when I test Tegra_Linux_Sample-Root-Filesystem_R32.1.0_aarch64.tbz2 it seems to be ok.

Anyone else facing this problem? I’m on an Ubuntu 18.04 laptop.

I’m encountering the same problem. I’m using Ubuntu 16.04 as my host OS.

I’ve completely removed L4T and even SDK manager from the machine and all downloaded files. SDK Manager fails due to the CRC error.

When I test the bz2 like you have I receive the same error.

Good to know it’s not a problem on my end, and yeah I tried removing everything and trying it again but it seems to be just a problem with those specific compressed files.

I also downloaded those files individually from the NVIDIA server and did a bzip2 test on them. They seem to be broken/corrupted at source.

I just got word that the problem is our bzip2 packages:

For 18.04:
sudo apt install bzip2=1.0.6-8.1 libbz2-1.0=1.0.6-8.1

For 16.04:
sudo apt install bzip2=1.0.6-8 libbz2-1.0=1.0.6-8

The offending package version is 1.0.6-8ubuntu0.1 which was released recently for CVE-2019-12900.

I found a similar error during my Jetson TX2 flash with JP4.2
Is it solved ?

The problem is with the bzip2 package update from Ubuntu, not from SDK Manager.

I was able to work around the problem by downgrading the bzip2 packages.

FYI–

I reported this issue earlier today:

https://bugs.launchpad.net/ubuntu/+source/bzip2/+bug/1834494

–tim

Thanks for the heads up D3_growe. I tried this but it looks like downgrading bzip2 and libz2-1.0 will result in the removal of a bunch of ROS-MELODIC packages for me.

Maybe there’s a different version of the packages that won’t remove ROS-MELODIC? I admit that I wasn’t very careful in which version I selected. Maybe someone here can confirm the best version to install?

I’ll look into it, but thanks for pointing this out, I appreciate it!

Thanks! Worked like a charm.
If others find trouble with installation, here are quick tips:

wget http://launchpadlibrarian.net/206950099/bzip2_1.0.6-8_amd64.deb wget http://launchpadlibrarian.net/206950098/libbz2-1.0_1.0.6-8_amd64.deb
sudo apt install bzip2_1.0.6-8_amd64.deb libbz2-1.0_1.0.6-8_amd64.deb sudo dpkg -i bzip2_1.0.6-8_amd64.deb libbz2-1.0_1.0.6-8_amd64.deb

Instead of downgrading the system bzip2, the following is a safer alternative (as it doesn’t require running the vulnerable version of bzip2 system-wide). This should also work for @singularity7.

download the .debs, unpack them, and set LD_LIBRARY_PATH and PATH so that that version of bzip2 will be used by sdkmanager:

cd $HOME && mkdir bzip2 && cd bzip2
wget http://launchpadlibrarian.net/206950099/bzip2_1.0.6-8_amd64.deb
wget http://launchpadlibrarian.net/206950098/libbz2-1.0_1.0.6-8_amd64.deb
dpkg -x bzip2_1.0.6-8_amd64.deb .
dpkg -x libbz2-1.0_1.0.6-8_amd64.deb .

LD_LIBRARY_PATH=$HOME/bzip2/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH PATH=$HOME/bzip2/bin:$PATH sdkmanager

Thanks @mvdf, I think this is the neatest solution and it doesn’t aggressively fight my existing libraries.

I have a very old version of BZIP2 and I still get similar errors:

bzip2, a block-sorting file compressor.  Version 1.0.6, 6-Sept-2010.

I’m seeing the following errors:

09:15:25 ERROR : Drivers for Jetson Nano :
09:15:25 ERROR : Drivers for Jetson Nano : tar: Unexpected EOF in archive
09:15:25 ERROR : Drivers for Jetson Nano : NV_L4T_DRIVERS_NANO_COMP command /tmp/tmp_NV_L4T_DRIVERS_NANO_COMP.sh finished with error
09:15:25 ERROR : Drivers for Jetson Nano : command terminated with error
09:28:01 ERROR : Drivers for Jetson Nano :
09:28:01 ERROR : Drivers for Jetson Nano : tar: Unexpected EOF in archive
09:28:01 ERROR : Drivers for Jetson Nano : NV_L4T_DRIVERS_NANO_COMP command /tmp/tmp_NV_L4T_DRIVERS_NANO_COMP.sh finished with error
09:28:01 ERROR : Drivers for Jetson Nano : command terminated with error

It appears the internal revision info was not updated in the latest release. Mine looks “old” as well:

tescott@system76-pc:~$ bzip2 --version
bzip2, a block-sorting file compressor.  Version 1.0.6, 6-Sept-2010.

   Copyright (C) 1996-2010 by Julian Seward.

   This program is free software; you can redistribute it and/or modify
   it under the terms set out in the LICENSE file, which is included
   in the bzip2-1.0.6 source distribution.

   This program is distributed in the hope that it will be useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
   LICENSE file for more details.

Here’s what apt-cache reports:

tescott@system76-pc:~$ sudo apt-cache policy bzip2
[sudo] password for tescott:
bzip2:
  Installed: 1.0.6-8.1ubuntu0.1
  Candidate: 1.0.6-8.1ubuntu0.1
  Version table:
 *** 1.0.6-8.1ubuntu0.1 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.6-8.1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

This was updated on 6/24/2019 according to: http://changelogs.ubuntu.com/changelogs/pool/main/b/bzip2/bzip2_1.0.6-8.1ubuntu0.1/changelog

–tim

Thank you Greg, I can confirm this works but be careful it will downgrade bzip2 and remove ROS packages too.
you can install it later on.

Best Regards,
Abdalrahman M. Amer

I can also confirm that downgrading the bzip2 version got my SDK to progress beyond the failure point at driver install, and it now starts to build the OS image and flash the Xavier module.

If you downgrade and retry it’s going to have the same effect as simply retrying if the download is being corrupted in transit by the CDN. That could explain it working the second time and not the first. Simply, you got a bad download the first time. I can confirm connectivity problems to Nvidia’s servers during the timeframe these prohlems have been happening. Perhaps it’s not the bzip2 version.

I thought it was a corruption problem before investigating the matter more fully. To test that corruption idea I copied archives from two of my colleagues PCs who had not updated their host systems as I had. bzip2 failed to verify those known good archives.

That does sound like bzip2. What’s strange is half the reports are concerning Nvidia tarballs and it’s at the same time as CDN issues, but I guess coincidences happen.