Jetpack 4.2.2 install failed using SDK Manager

I’m encountering errors with the install process when using SDK Manager. This is the filtered list of errors that I got from the logs:

DETAILS TERMINAL
Component Name: All
Error

Filter text here...

12:48:05 ERROR : Drivers for Jetson TX2 & TX2i :
12:48:05 ERROR : Drivers for Jetson TX2 & TX2i : tar: Unexpected EOF in archive
12:48:05 ERROR : Drivers for Jetson TX2 & TX2i : Run commands failed at step Install: command /tmp/tmp_NV_L4T_DRIVERS_TX2_COMP.sh finished with error
12:48:05 ERROR : Drivers for Jetson TX2 & TX2i : command terminated with error
12:48:05 ERROR : install 'Drivers for Jetson TX2 & TX2i' failure, command < cd '/home/klass/nvidia/nvidia_sdk/JetPack_4.2.2_Linux_GA_P3310' ; '/opt/nvidia/sdkmanager/resources/app/output/installUtils/adapter' -a='install' -c='eyJpZCI6Ik5WX0w0VF9EUklWRVJTX1RYMl9DT01QIiwibmFtZSI6IkRyaXZlcnMgZm9yIEpldHNvbiBUWDIgJiBUWDJpIiwiZGVzY3JpcHRpb24iOiJOVklESUEgVGVncmEgTGludXggRHJpdmVyIFBhY2thZ2UiLCJjb21wVHlwZSI6InRhcmdldF9pbWFnZSIsImlzVmlzaWJsZSI6dHJ1ZSwibGljZW5zZUlkIjoiTlZfSkVUUEFDS19PU19FVUxBIiwiaXNEZXRlY3RhYmxlSW5zdGFsbCI6ZmFsc2UsImlzSW5zdGFsbFBhdGhDdXN0b21pemFibGUiOnRydWUsInZlcnNpb24iOiIzMi4yIiwib3BlcmF0aW5nU3lzdGVtcyI6WyJ1YnVudHUxNjA0IiwidWJ1bnR1MTgwNCJdLCJpbnN0YWxsU2l6ZU1CIjozNTYsImRvd25sb2FkRmlsZXMiOlt7InVybCI6IlAzMzEwL0pldHNvbl9MaW51eF9SMzIuMi4xX2FhcmNoNjQudGJ6MiIsImZpbGVOYW1lIjoiSmV0c29uX0xpbnV4X1IzMi4yLjFfYWFyY2g2NC50YnoyIiwic2l6ZSI6MTMxMDM3NzEwLCJjaGVja3N1bSI6IjQ3YTdiNDNmMTE5ODg4Zjc1MDZhNmZmNDQ3ZjQzMDM2IiwiY2hlY2tzdW1UeXBlIjoibWQ1IiwiaW5zdGFsbFBhcmFtZXRlcnMiOnsiaW5zdGFsbFR5cGUiOiJjbWQiLCJhZGRpdGlvbmFsUGFyYW1ldGVycyI6eyJpbnN0YWxsRGlyIjoie3tUQVJHRVRfUk9PVH19L3t7QlVORExFX1RJVExFfX1fe3tCT0FSRF9JRH19IiwiaW5zdGFsbENvbW1hbmRzIjpbeyJleGVjQmFzaCI6WyJzdWRvIGFwdC1nZXQgdXBkYXRlIHx8IHRydWUiLCJzYWZlX2FwdF9pbnN0YWxsIFwic3VkbyBhcHQtZ2V0IGluc3RhbGwgLXkgcGlneiBsYnppcDJcIiA1IiwidGFyIHhwZiB7e0ZJTEVfUEFUSH19Il19XX19LCJjYWNoZWRVcmwiOiJodHRwczovL2RldmVsb3Blci5kb3dubG9hZC5udmlkaWEuY29tL2RldnpvbmUvZGV2Y2VudGVyL21vYmlsZS9qZXRwYWNrX2w0dC9KRVRQQUNLXzQyMl9iMjEvUDMzMTAvSmV0c29uX0xpbnV4X1IzMi4yLjFfYWFyY2g2NC50YnoyIiwiY3VycmVudERvd25sb2FkZWRVcmwiOiJodHRwczovL2RldmVsb3Blci5kb3dubG9hZC5udmlkaWEuY29tL2RldnpvbmUvZGV2Y2VudGVyL21vYmlsZS9qZXRwYWNrX2w0dC9KRVRQQUNLXzQyMl9iMjEvUDMzMTAvSmV0c29uX0xpbnV4X1IzMi4yLjFfYWFyY2g2NC50YnoyIn1dLCJ0YXJnZXRJZHMiOlsiUDMzMTAiLCJQMzQ4OS0wMDAwIiwiUDM0ODktMDA4MCJdLCJkZXBlbmRlbmNpZXMiOltdLCJleHRlcm5hbF9kZXBlbmRlbmNpZXMiOltdLCJ0YXJnZXRJRCI6IlAzMzEwIiwiX2lkIjoiTlZfTDRUX0RSSVZFUlNfVFgyX0NPTVBAUDMzMTAiLCJwYXJlbnRJRCI6Ik5WX0pFVFBBQ0tfTDRUX0lNQUdFX1NFVFVQX1RBUkdFVF9HUk9VUCIsIl9wYXJlbnRJRCI6Ik5WX0pFVFBBQ0tfTDRUX0lNQUdFX1NFVFVQX1RBUkdFVF9HUk9VUEBQMzMxMCIsImluc3RhbGxTdGF0dXMiOiJub25lIiwiYWN0aW9uIjoxLCJkb3dubG9hZEVycm9ycyI6W10sImV4ZWMiOiIvaG9tZS9rbGFzcy9Eb3dubG9hZHMvbnZpZGlhL3Nka21fZG93bmxvYWRzL0pldHNvbl9MaW51eF9SMzIuMi4xX2FhcmNoNjQudGJ6MiIsImJ1bmRsZVRpdGxlIjoiSmV0UGFja180LjIuMl9MaW51eF9HQSIsImluc3RhbGxQYXRoIjoiL2hvbWUva2xhc3MvbnZpZGlhL252aWRpYV9zZGsvSmV0UGFja180LjIuMl9MaW51eF9HQV9QMzMxMCIsImluc3RhbGxSb290IjoiL2hvbWUva2xhc3MvbnZpZGlhL252aWRpYV9zZGsiLCJib2FyZElEIjoiUDMzMTAiLCJ0YXJnZXRBY2Nlc3NJbmZvIjp7InVzZXIiOiIiLCJwYXNzd29yZCI6IiIsImhvc3QiOiIxOTIuMTY4LjU1LjEiLCJwb3J0IjoiMjIifSwiaXNEcnlSdW4iOmZhbHNlfQ==' -i='NV_L4T_DRIVERS_TX2_COMP' -v='32.2' -l='/home/klass/nvidia/nvidia_sdk/JetPack_4.2.2_Linux_GA_P3310' -L='/home/klass/.nvsdkm/logs/JetPack_4.2.2_Linux_GA' -p='38' -t='P3310' -e='/home/klass/Downloads/nvidia/sdkm_downloads/Jetson_Linux_R32.2.1_aarch64.tbz2' > terminated with error
12:48:24 ERROR : NVIDIA Nsight Systems : update-alternatives: error: alternative path is not absolute as it should be:
12:48:24 ERROR : NVIDIA Nsight Systems : update-alternatives: error: alternative path is not absolute as it should be:
12:51:32 ERROR : CUDA on Host : debconf: unable to initialize frontend: Dialog
12:51:32 ERROR : CUDA on Host : Extracting templates from packages: 26%
12:51:33 ERROR : CUDA on Host : Extracting templates from packages: 52%
12:51:34 ERROR : CUDA on Host : Extracting templates from packages: 78%
12:51:34 ERROR : CUDA on Host : Extracting templates from packages: 100%
12:52:58 ERROR : OpenCV on Host : dpkg: dependency problems prevent configuration of libopencv:
12:52:58 ERROR : OpenCV on Host : Errors were encountered while processing:
12:52:58 ERROR : OpenCV on Host : E
12:52:58 ERROR : OpenCV on Host : : Unmet dependencies. Try using -f.
12:53:34 ERROR : OpenCV on Host : debconf: unable to initialize frontend: Dialog
12:53:35 ERROR : OpenCV on Host : Extracting templates from packages: 76%
12:53:35 ERROR : OpenCV on Host : Extracting templates from packages: 100%
12:53:45 ERROR : CUDA Cross Compile Package on Host : W: The repository 'http://archive.ubuntu.com/ubuntu xenial Release' does not have a Release file.
12:54:19 ERROR : CUDA Cross Compile Package on Host : debconf: unable to initialize frontend: Dialog
12:54:19 ERROR : CUDA Cross Compile Package on Host : Extracting templates from packages: 85%
12:54:20 ERROR : CUDA Cross Compile Package on Host : Extracting templates from packages: 100%
12:56:17 ERROR : VisionWorks on Host : debconf: unable to initialize frontend: Dialog
12:56:18 ERROR : VisionWorks on Host : Extracting templates from packages: 33%
12:56:18 ERROR : VisionWorks on Host : Extracting templates from packages: 67%
12:56:19 ERROR : VisionWorks on Host : Extracting templates from packages: 100%
12:56:36 ERROR : VisionWorks on Host : debconf: unable to initialize frontend: Dialog
12:56:42 ERROR : VisionWorks on Host : debconf: unable to initialize frontend: Dialog
12:56:43 ERROR : Unavailable components detected, please check log
12:56:43 ERROR : File System and OS Skipped. Due to its dependencies fail to install: Drivers for Jetson TX2 & TX2i,
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
12:56:44 ERROR : Flash skipped due to component(s) download/install failure
INSTALLATION FAILED 
Please review the terminal tab for details. Resolve and RETRY.
EXPORT LOGS

RETRY
FAILED ITEMS

STOP TRYING

Copyright © 2019,
 
NVIDIA CORPORATION
. 
All rights reserved.
 | 
NVIDIA Developer

I believe there was a similar thread from earlier that reported the same issue (but I think got buried in the noise). Installing Jetpack 4.2.1 works by the way.

Could you please help to resolve this?

Hi klassesnvidia,

Are you connect Ethernet cable on your host machine?
Are you got this error every time?
Thanks!

Yes, definitely connected. In fact I’m browsing this forum on the same host. And yes, the error occurs every time for 4.2.2. Again, 4.2.1 works fine.

If it’s also relevant information, we’re located in Singapore.

Hi klassesnvidia,

Can you please zip the ~/.nvsdkm directory and attach it here for further investigation?

I have same ERROR in my jetson Xavier

11:43:40 ERROR : NVIDIA Nsight Systems : update-alternatives: error:
11:43:40 ERROR : NVIDIA Nsight Systems : alternative path is not absolute as it should be:
11:43:40 ERROR : NVIDIA Nsight Systems :
11:43:40 ERROR : NVIDIA Nsight Systems : update-alternatives: error:
11:43:40 ERROR : NVIDIA Nsight Systems : alternative path is not absolute as it should be:
11:43:40 ERROR : NVIDIA Nsight Systems :

how can i do this

Hi skagusg,

Can you please zip the ~/.nvsdkm directory and attach it here for further investigation?

My JP 4.2.2. installation fails for a slightly different reason, there are a number of URLs pointing to non-existing UBUNTU files when the SDK Manager tries to install Visionworks:

15:09:34 INFO : VisionWorks on Host : 404 Not Found [IP: 141.30.62.25 80]
15:09:35 INFO : VisionWorks on Host : Err:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgstreamer-plugins-base1.0-dev amd64 1.8.3-1ubuntu0.2
15:09:35 INFO : VisionWorks on Host : 404 Not Found [IP: 141.30.62.25 80]
15:09:35 INFO : VisionWorks on Host : Get:5 file:/var/visionworks-repo libvisionworks-samples 1.6.0.500n [54.4 MB]
15:09:35 ERROR : VisionWorks on Host : E
15:09:35 ERROR : VisionWorks on Host : : Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/glib2.0/libglib2.0-dev_2.48.2-0ubuntu4.1_amd64.deb 404 Not Found [IP: 141.30.62.25 80]
15:09:35 INFO : VisionWorks on Host :
15:09:35 INFO : VisionWorks on Host : E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base1.0/libgstreamer-plugins-base1.0-dev_1.8.3-1ubuntu0.2_amd64.deb 404 Not Found [IP: 141.30.62.25 80]
15:09:35 INFO : VisionWorks on Host :
15:09:35 INFO : VisionWorks on Host : E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
15:09:35 INFO : VisionWorks on Host : [ Package Install Finished with Error ]
15:09:35 INFO : VisionWorks on Host : [ 40.00 KB used. Disk Avail: 114.90 GB ]
15:09:35 INFO : VisionWorks on Host : [ NV_VISIONWORKS_HOST_COMP Install took 21s ]
15:09:35 ERROR : VisionWorks on Host : apt install failed
15:09:35 INFO : VisionWorks on Host :
15:09:35 ERROR : VisionWorks on Host : command terminated with error

Hi EdwardZhou

Can you please zip the ~/.nvsdkm directory and attach it here for further investigation?

how can i do for you? i don’t understand

Hi skagusg,

All installation logs can be found in the ~/.nvsdkm directory on host. You can check by running the ls -al ~/.nvsdkm command on your PC. We need check through the details in this directory for further investigation.

Hi mtbsteve,

The error shows there is network issue. You cannot run ‘sudo apt-get update’ successfully on your host (PC). I’m not sure whether this is a temporary ubuntu repository server issue or your local network issue.

Thanks EdwardZhou
i will install jetpack xavier

That zip file is the file after installing the sdk manager on the hostcomputer that just installed Ubuntu 18.04.
  Next time how can i do for install jetpack on my xavier
nvsdkm.zip (3.49 KB)

Hi skagusg,

The log files are incomplete. Also the sdkm.db file shows nothing is installed. Can you please double check if this is the correct log file?

Hi edward

Nothing happens after reinstalling Ubuntu 18.04

Would i like to show “nvsdkm.zip” after using SDKmanager?

Hi skagusg,

Are you using CLI mode to install SDKManager? If so, what command are you using?
After installation with SDKManager, the logs in ~/.nvsdkm directory will get updated. Please zip the ‘~/.nvsdkm’ directory and update here. The directory should contain additional sub-directories. For example, dist/, logs/, replays/. Please make sure the zip file contains all the files in your ‘~/.nvsdkm’ directory. Thanks.

Thanks EdwardZhou,

I install SDKmanager in this site https://developer.nvidia.com/embedded/jetpack?source=post_page-----f9c00f669680----------------------

and use sudo apt install ./sdkmanager_0.9.14-4954_amd64.deb code in Terminal

and sudo apt-get update

and sudo reboot

and make nvsdkm.zip using this code : zip -r nvsdkm.zip ~/.nvsdkm/

my .nvsdkm/ list
drwxr-xr-x 2 rcvlab rcvlab 4096 9월 4 11:16 .
drwxr-xr-x 20 rcvlab rcvlab 4096 9월 4 15:20 …
-rw-r–r-- 1 rcvlab rcvlab 36864 9월 4 11:04 sdkm.db
-rw-r–r-- 1 rcvlab rcvlab 11654 9월 4 11:04 sdkm.log

Thanks

Hi skagusg,

Sorry I didn’t explain clearly. I need the installation log when installing JetPack with SDKManager client. Not the log to install SDKManager client itself.

  1. After installing SDKManager client as the steps you shown in comment #14, please login with SDKManager, see https://docs.nvidia.com/sdk-manager/download-run-sdkm/index.html#login. Since you want to install JetPack, please select “NVOnline” when you log in.
  2. After login, please install JetPack with SDKManager client. For example, see steps at https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html
  3. After installation, please zip the ‘~/.nvsdkm’ directory and update the log.

Hi EdwardZhou

I am permission denied NVOnline, how can install developer

I install according to this link : https://developer.nvidia.com/nvidia-sdk-manager but every time has ERROR

11:43:40 ERROR : NVIDIA Nsight Systems : update-alternatives: error:
11:43:40 ERROR : NVIDIA Nsight Systems : alternative path is not absolute as it should be:
11:43:40 ERROR : NVIDIA Nsight Systems :
11:43:40 ERROR : NVIDIA Nsight Systems : update-alternatives: error:
11:43:40 ERROR : NVIDIA Nsight Systems : alternative path is not absolute as it should be:

like this

thanks for getting back. I can confirm that it is not a network issue. I can access the ubuntu servers, but

sudo apt-get update

fails to download the following archives which simply do not exist at security.ubuntu.com.

Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libglib2.0-dev amd64 2.48.2-0ubuntu4.1
  404  Not Found [IP: 141.30.62.25 80]
Ign:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgstreamer-plugins-base1.0-dev amd64 1.8.3-1ubuntu0.2
Get:3 file:/var/visionworks-repo  libvisionworks 1.6.0.500n [12.3 MB]
Get:4 file:/var/visionworks-repo  libvisionworks-dev 1.6.0.500n [154 kB]
Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libglib2.0-dev amd64 2.48.2-0ubuntu4.1
  404  Not Found [IP: 141.30.62.25 80]
Err:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libgstreamer-plugins-base1.0-dev amd64 1.8.3-1ubuntu0.2
  404  Not Found [IP: 141.30.62.25 80]
Get:5 file:/var/visionworks-repo  libvisionworks-samples 1.6.0.500n [54.4 MB]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/glib2.0/libglib2.0-dev_2.48.2-0ubuntu4.1_amd64.deb  404  Not Found [IP: 141.30.62.25 80]

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base1.0/libgstreamer-plugins-base1.0-dev_1.8.3-1ubuntu0.2_amd64.deb  404  Not Found [IP: 141.30.62.25 80]

Any idea how I can fix this? I have the logfiles from my installation attached.

SDKM_logs_JetPack_4.2.2_Linux_2019-09-03_15-09-10.zip (337 KB)

Hi EdwardZhou,

After install jetpack in my jetson xavier

and this is my “zip the ‘~/.nvsdkm’”

Thanks
nvsdkm.zip (499 KB)

Hi skagusg,

I’ve forwarded the issue you found to our internal team for more investigation.