The Flicker Returns! 535.54.03 driver

Yup, it’s indeed back :(

[~]@outstanding
λ pacman -Q nvidia
nvidia 535.54.03-3
[~]@outstanding
λ sudo cat /sys/module/nvidia_drm/parameters/modeset 
Y
[~]@outstanding
λ uname -rs
Linux 6.3.9-arch1-1
[~]@outstanding
λ xrandr | grep primary
DP-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 598mm x 336mm

Hello all. I have the same issue with the following settings:
NVIDIA GeForce RTX 4080 GPU/PCIe/SSE2
Graphic Platform X11
kernel 6.4.0.
modest Y
DP-0 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 344mm x 215mm
535.54.03

The hardware is a Lenovo Legion Pro 7 16IRX8H laptop running Ubuntu 23.04.
With the 515 driver series, this was not occurring. I’ve noticed that flickering appears only on top of the screen.
PS, it started appearing with 535.x series (even on previous beta drivers)

I am also experiencing a steady rate of intermittent flickering once every 15-30 seconds using proprietary Nvidia drivers.

Nvidia Driver Version: 535.54.03

GPU: GeForce GTX 1650

Screen Resolution: 2560x1440 @ 144Hz refresh rate

OS: Arch Linux Kernel 6.1.37-1-lts

Desktop: Gnome 44.2 & GDM 44.1 with X11 (X Server Windowing System)

This wasn’t an issue prior to upgrading to 535.54.03. Hope they provide a fix soon.


Caught on tape…

I don’t notice anything when playing games, everything is ok on the top screen as well. But the desktop (KDE NEON 22.04) does not run so smart anymore. There it did not before.

Driver directly from the Ubuntu Repoitory 535.54.03
Nvidia GTX 4090
Resolution 5120x1440

After fresh install of Fedora 38 everything was ok with default drivers…after installing both first NVIDIA 530, and then, 535 there was a random flicker in the top of the screen…in the game i didnt notice it though…i assume that it has to do with Xorg11 and wayland windowing system,i also use G-sync dell monitor with 165 hz refresh rate…ill put my whole hardware config here for more details just in case.

 Kernel: 6.3.8-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.2 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
Machine:
  Type: Desktop Mobo: ASRock model: H97 Pro4 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P2.10 date: 03/07/2018
CPU:
  Info: quad core model: Intel Core i7-4790S bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 927 high: 1355 min/max: 800/4000 cores: 1: 800 2: 1264
    3: 798 4: 800 5: 800 6: 800 7: 1355 8: 800 bogomips: 51087
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: ASUSTeK
    driver: nvidia v: 535.54.03 arch: Turing pcie: speed: 2.5 GT/s lanes: 16
    ports: active: none off: DP-1 empty: DVI-D-1,HDMI-A-1,HDMI-A-2
    bus-ID: 01:00.0 chip-ID: 10de:1f08
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
    gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: DP-1 mapped: DP-0 note: disabled model: Dell G2422HS
    res: 1920x1080 dpi: 93 diag: 595mm (23.4")
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX
    2060/PCIe/SSE2 direct-render: Yes
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f9
  Device-2: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster
    Audigy Series] driver: snd_emu10k1 v: kernel bus-ID: 04:00.0
    chip-ID: 1102:0004
  Device-3: Generalplus Redragon GM99 microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 bus-ID: 2-2:2 chip-ID: 1c5f:2014
  API: ALSA v: k6.3.8-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: kernel
    port: f040 bus-ID: 00:19.0 chip-ID: 8086:15a1
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 109.56 GiB (11.8%)
  ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 931.02 GiB used: 109.56 GiB (11.8%) fs: btrfs dev: /dev/sda3
  ID-2: /home size: 931.02 GiB used: 109.56 GiB (11.8%) fs: btrfs
    dev: /dev/sda3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 325 Uptime: 6h 47m Memory: available: 15.54 GiB
  used: 4.42 GiB (28.4%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: gcc: 13.1.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 21 Shell: Bash v: 5.2.15
  running-in: gnome-terminal inxi: 3.3.27

Hi All,
I have seen flickering of entire screen on my setup locally and we are actively debugging the issue.
Bug 4164132 has been also raised for the same.

3 Likes

Just an update (if it was needed) but the update 535.54.03 => 535.86.05 does not fix the issue.

535.86.10 doesn’t fix the issue either.

No luck with 535.98 either. Still flickering :(

Comically my flicker is no longer at the top of the screen but seems to rip through the middle. (Slow Clap) Good Jorb! I will note it’s a lot less frequent though. It used to happen fairly consistently every few minutes but now I just catch maybe 2 or 3 a day…but it’s still happening. The fact it’s “lower” on the screen does suggest some whacky timing issue though.

As a side note (for me at least) I noticed for well over a year the nVidia settings panel never correctly loads my settings which in theory can imply any timings I’ve set are constantly “lost” and things just go back to possibly bad defaults.

I was facing this issue even on 535.98 using the nvidia-dkms package while using 6.1.46-1-lts kernel on arch linux. But that changed when I switched to nvidia-lts package instead. Now I almost get no flickers. Very rarely I see like a few flickers on the top portion of my screen, still running my monitor at 2560x1440 @ 144Hz refresh rate.

It’d be great if someone else can confirm if this is a one-off or a reproducible observation. Thanks.

Flickering not solved for me in the new nvidia driver (535.98) and the changelog told us its fixed but its not.

We have this flickering issue since full 5 month now (Very short black flickering (flashes) with nvidia 2080Ti since nvidia 530.41.03 driver) and still not the slightest info that nvidia is trying to fix it.

Nvidia Driver Version: 535.98

GPU: GeForce GTX 2080Ti

Screen Resolution: 2560x1440 @ 144Hz

OS: Manjaro Linux Kernel 6.1.44-1 LTS

Desktop: KDE with X11

Unfortunately there are a few glaring issues I’ve had with my nVidia cards with no mention of if they will ever be fixed. This is iirc 4 driver updates with the flicker. The fact they think it’s fixed in the latest release gives me little assurance any of the issues I’ve open will be addressed. At this rate it’s a sad possibility waiting for the open source drivers might be the only hope anything gets done…which could still be years off. This should be part of the marketing. Bad prices, underwhelming performance and stranding customers with broken drivers…nVidia, it’s how it’s disma(pla)yed. /rant

I had the same problem for atleast 1-2years, my colour settings reseting to default when i had to start x server UI again… but when i don’t touch it, my settings are stored.

2 weeks ago they could finally reproduce it, but till waiting for the confirmation for the final fix.

Mine are saved in the config but the nVidia settings can’t load via the syntax it saved. Seems like the now too common stupidity where the settings panel understands to save correctly based on which GPU has what set but the load portion has had the GPU denotation bit removed causing all settings for all GPU’s to just be ignored and “default.”

I load them with nvidia-settings -l

Btw. the new nvidia driver 535.129.03 get rid of the flickering for me.

RTX4090 here on Ubuntu 23.10 and Nvidia Driver 535.129.03

I have an Acer X32FP 4K 160Hz, it works well at 120Hz and below, it flicker at 144Hz and 160Hz.

Please fix it …

Hi all,

Just bought Lenovo Legion Pro 5, with NVIDIA 4060. On Ubuntu, with Ubuntu automatically selected version of gpu drivers, I am sometimes getting flickering of the upper part of display, primarily when I watch video or YT. After reading this thread, I am only glad that it seems not a hardware issue:)

Will try 545.23.06 version

Thanks

Alex

I use --load-config-only but the settings do not understand their own syntax. This is a growing issue where multi XScreen “remnants” remain while their functionality is broken because no one is paying attention to them anymore (assuming they are dead or unused.) This is all GTK/Wayland’s doing but the end result is I can save things but then it doesn’t comprehend how to load what it saved because the syntax is broken.

So when I save the syntax is “hostname:XScreen/setting” but when you load the loading process has no clue what the XScreen portion is and tosses errors.

It’s might also be worth noting the inconsistency in the settings. In some places hostname:XScreen/setting in others GPU:#/setting and in others yet still GPU_#.

[GPU:0]/GPUPowerMizerMode=2
[GPU:1]/GPUPowerMizerMode=0
Timer = Memory_Used_(GPU_0),Yes,3000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Memory_Used_(GPU_1),Yes,3000
Timer = Thermal_Monitor_(GPU_1),Yes,1000
Timer = PowerMizer_Monitor_(GPU_1),Yes,1000
hostname:0.0/SyncToVBlank=1
hostname:0.0/LogAniso=0
hostname:0.0/FSAA=0
hostname:0.0/TextureClamping=1
hostname:0.0/FXAA=0
hostname:0.0/AllowFlipping=1
hostname:0.0/FSAAAppControlled=0
hostname:0.0/LogAnisoAppControlled=1
hostname:0.0/OpenGLImageSettings=3
hostname:0.0/FSAAAppEnhanced=0
hostname:0.0/ShowGraphicsVisualIndicator=0
hostname:0.0/XVideoSyncToDisplayID=DP-2
hostname:0.1/SyncToVBlank=1
hostname:0.1/LogAniso=0
hostname:0.1/FSAA=0
hostname:0.1/TextureClamping=1
hostname:0.1/FXAA=0
hostname:0.1/AllowFlipping=1
hostname:0.1/FSAAAppControlled=0
hostname:0.1/LogAnisoAppControlled=1
hostname:0.1/OpenGLImageSettings=3
hostname:0.1/FSAAAppEnhanced=0
hostname:0.1/ShowGraphicsVisualIndicator=0
hostname:0.1/XVideoSyncToDisplayID=HDMI-0