The position of the apriltag is incorrect

Hello, I ran the tutorial from 13. April Tags — Omniverse IsaacSim latest documentation. I made some modifications, placing the camera at position (0, 0, 0), as shown in the figure below.
2023-09-05 22-01-05 的屏幕截图

I placed the apriltag_id1 at position (-1, 0.1, 0), and set the scale of y and z to 0.001.
2023-09-05 22-03-30 的屏幕截图

Then, I modified the apriltag_continuous_detection.launch file as follows:
{‘id’: 1, ‘size’: 0.1, ‘name’: tag_1}
param name=“publish_tf” type=“bool” value=“true”

After that, I ran the program and executed the command: rosrun tf tf_echo /world /tag_1. The coordinates of the detected tag_1 were:

  • Translation: [-0.455, 0.125, 0.000]
  • Rotation: in Quaternion [0.004, 0.708, -0.003, 0.706]
    in RPY (radian) [3.072, 1.567, 3.062]
    in RPY (degree) [175.993, 89.808, 175.413]

As we can see, the detected coordinates (-0.455, 0.125) differ significantly from the actual coordinates (-1, 0.1). What should I do to correct this? Thank you, welcome all suggestions.
april_tag.usd (13.5 KB)

Hi @light2000,

Could you try re-running your setup in the latest the release IsaacSim 2023.1.0 to see if the issue is now resolved?

Hi @Ayush_G , I am using the latest version of IsaacSim 2023.1.1 and running the tutorial code from the latest Git repository. The scale for apriltag_id 1 is set to 0.00125 because the apriltag’s size does not include the edges.
After retesting, when running “rosrun tf tf_echo /world /tag_1”, the coordinates of the detected tag_1 are: Translation: [-0.362, 0.1, 0.000].
The Y and Z coordinates seem correct, but the X coordinate appears to be incorrect.
When set_x = -1.0, the detected_x is -0.362.
When set_x = -1.5, the detected_x is -0.543.

How can I fix this issue? Thank you. (6.2 KB)