Tlt docker pull is running every time I run the tao action_recognition


print("Train RGB only model from scratch")
    !tao action_recognition train \
                  -e $SPECS_DIR/train_rgb_2d.yaml \
                  -r $RESULTS_DIR/rgb_2d \
                  -k $KEY \
                  dataset_config.train_dataset_dir=$DATA_DIR/train \

When I run this cell, the program is stopped by showing below log.

Train RGB only model from scratch
2022-03-11 15:02:21,279 [INFO] root: Registry: ['']
2022-03-11 15:02:21,365 [INFO] tlt.components.instance_handler.local_instance: Running command in container:
2022-03-11 15:02:21,579 [INFO] tlt.components.docker_handler.docker_handler: The required docker doesn't exist locally/the manifest has changed. Pulling a new docker.
2022-03-11 15:02:21,579 [INFO] tlt.components.docker_handler.docker_handler: Pulling the required container. This may take several minutes if you're doing this for the first time. Please wait here.
Pulling from repository:
2022-03-12 11:03:16,969 [INFO] tlt.components.docker_handler.docker_handler: Container pull complete.
2022-03-12 11:03:16,970 [WARNING] tlt.components.docker_handler.docker_handler: 
Docker will run the commands as root. If you would like to retain your
local host permissions, please add the "user":"UID:GID" in the
DockerOptions portion of the "/home/ahamad/.tao_mounts.json" file. You can obtain your
users UID and GID by using the "id -u" and "id -g" commands on the

I tried tao action_recognition --helpfrom the terminal, even there I got the same response. What should I do.

Can you run “$docker ps” in the terminal instead of jupyter notebook to check if the tao-toolkit-pyt docker is already available?

1 Like

I got it. I opened the specified .tao_mounts.json and added "user":"UID:GID" in DockerOptions. The issue is resolved now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.