TOUCH_CLK - B24 pin as GPIO

we need to use the Jetson TX2 TOUCH_CLK - B24 pin as a GPIO output pin. We tried to find information to calculate the GPIO userspace pin number on the Jetson TX2 PINMUX sheet. Unfortunately, we have not been able to find all the required details.

Could you please help us?

Thanks in advance for your help.


hello domey4x13,

please check developer guide for [Jetson TX2 Platform Adaptation and Bring-Up] chapter,
you may refer to GPIO Changes session for an example to check the GPIO number. thanks

as mentioned above, the problem is that we have not been able to find the details needed to calculate the GPIO number of TOUCH_CLK (port name and port number). As you can see from the attached picture, the details of the GPIO port and port number are not reported in the document.

hello domey4x13,

may I know what’s your actual use-case?
it’s pin muxing in the spreadsheets, TOUCH_CLK is default defined as SFIO; there’s no options to configure it as GPIO pin.

thanks for your answer. We designed and produced a custom carrier board for the Jetson TX2. Due to an error, our HW engineer used B24 pin instead of B25 pin in its design. Our problem is that we need to activate an external circuit using the B24 pin and, hence, we were looking for a way to drive the B24 pin high.

B24 maps to GPIO EE.02 which maps to #306. See this post for a simple table:

Note that sometimes the GPIOs only work as inputs because of a SoM buffer that keeps the outside world from directly accessing the GPIO.

Hello JDSchroeder,
thank you so much for your help. We have just tried using gpio #306 and it works perfectly.
Could you please tell us where did you find that B24 maps to GPIO EE.02?


Open <Linux_for_Tegra>/bootloader/t186ref/BCT/tegra186-mb1-bct-pinmux-quill-p3310-1000-c03.cfg
and search for touch_clk. You will find in the comments it is called touch_clk_pee2 at address 0x0c302000. The “p” not part of the GPIO port naming. ee indicates the port. The number 2 indicates the offset within that port for the GPIO. So you get the GPIO naming EE.02.

Thanks you so much JDSchroeder. It seems to me that Nvidia documentation is quite confused. Even Nvidia reported that the pin was not usable as GPIO in a previous answer.

hello domey4x13,

it should be documentation erroneous, we’re checking why there’s no GPIO options.

could you please have modification in device tree, (i.e. TEGRA_GPIO(EE, 2)) to check whether it works or not.

As said before, the solution proposed by JDSchroeder works. If Nvidia has the money to provide you with a Jetson TX2 you can test his solution as well.

hello domey4x13,

all the signals which are coming out of CVM and can be configured as GPIO,
we’ll have documentation updates, thanks

hello @domey4x13,

please check Jetson download center,

we had update the Jetson TX2 Series Pinmux, the latest version is now v1.07