TX2 NX CSI Cameras

I am trying to get our sensor modules to work with the TX2 NX modules. For this I modify the device tree as usual and start with disabling the RaspiCam / IMX219 driver that is enabled by default. I do so by commenting out the following line in the “tegra186-p3636-0002-p3509-0000-a01.dts”:

#include "common/tegra186-camera-lanai-rbpcv2-imx219.dtsi"

If I try to use this DTB, the kernel does not boot anymore. I would expect the module to boot as normal, just with the image sensors disabled, but it does just restart after the bootloader tries to start the kernel. How would I disable the IMX219 sensor from the device tree?

Try add status = “disabled” to disable it.