Uart1 hardware corresponding node on TX2

Dear,

I want to use UART1 to GPS on TX2(R32.5.1).Don’t know the corresponding node,i try ttyTHS1 ttyTHS3,ttyUSB0~ttyUSB3,ttyS0,but no GPS data.

hello shaorui,

please gather kernel init messages for all register UARTs.
for example,

$ dmesg | grep THS
[    1.089191] 3110000.serial: ttyTHS1 at MMIO 0x3110000 (irq = 37, base_baud = 0) is a TEGRA_UART
[    1.090049] c280000.serial: ttyTHS2 at MMIO 0xc280000 (irq = 38, base_baud = 0) is a TEGRA_UART
[    1.090960] 3130000.serial: ttyTHS3 at MMIO 0x3130000 (irq = 39, base_baud = 0) is a TEGRA_UART

you may download pinmux spreadsheets to check the signal names,
for example, it’s pin-203, uart3_tx_pw2, and pin-205, uart3_tx_pw3.
you may also mapping this with the board configuration file, tegra186-mb1-bct-pinmux-quill-p3310-1000-c03.cfg
for example,
pinmux.0x0c302020 = 0x00000400; # uart3_tx_pw2: uartc, tristate-disable, input-disable, lpdr-disable
when you looking into device tree. you’ll see the definition for using… uartc: serial@c280000

please mapping this to the kernel init messages, this is actually… ttyTHS2.

dmesg | grep THS
[    0.950519] 3110000.serial: ttyTHS1 at MMIO 0x3110000 (irq = 33, base_baud = 0) is a TEGRA_UART
[    0.952357] 3130000.serial: ttyTHS3 at MMIO 0x3130000 (irq = 34, base_baud = 0) is a TEGRA_UART

I cannot find ttyTHS2.

Dear,

I try NANO and NX_Xavier to ttyTHS receive data on same Bottom plate(I’m working in our custom carrier board with TX2).but NX no GPS data,I feel uart1 is a problem on TX2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.