Ubuntu 14.10 346.35 driver - TTY(1-6) console diplay blank

Hallo,

on my new Asus ROG G751jy (Nvidia GTX 980m, 1920x1080i display). I installed Ubuntu 14.10 and the 346.35 driver since that I’m not able to switch to the tty 1-6 console displays (ctrl+alt+F1 to F6). The screen is blank and the login is not visable. The boot menu (grub) itself is displayed in a correct way with different resolutions I tried.
I tried a lot of things in /etc/default/grub

GRUB_DEFAULT=5
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="" #tried: "nosplash", "vga=xxx", "quiet splash", "nomodeset" ... 
GRUB_CMDLINE_LINUX=""
# GRUB_TERMINAL=console #tried activated and deacitvated
GRUB_GFXMODE=1920x1080 #tried different graphic modes gathered from vbeinfo command in grub console
GRUB_GFXPAYLOAD_LINUX=keep #tried keep, text

Nothing helped yet.

I need the Nvidia driver to be installed, because I’m gaming on this computer.

I hope to get any advices.

Thanks for response

Kitsab

try nomodeset vga=normal rdblacklist=nouveau nouveau.modeset=0

Meanwhile, you’re doing it wrong:

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Hallo,

thank you for the quick reply, but your suggested configuration
“nomodeset vga=normal rdblacklist=nouveau nouveau.modeset=0”
also didn’t work.

I followed the link to the Ubuntu help community. The guides and faq’s are not related to my issue.

Maybe I’ve got to tell, the console displays tty1 to tty6 are responding to my blind entries, but the shell is not visible.

Thanks for suportand suggestions.

Kitsab

Until nvidia adds support for kms, you would be better off by using framebuffer driver called uvesafb. There are old how-tos for using it laying on the net and I’m not sure are they usefull for newer ubuntu’s anymore. But check i.e.

At least there’s no hwinfo anymore in newer ubuntu’s so you should use resolution according to grub’s vbeinfo.

Probably OP hasn’t consoles allocated on ttys. If he uses upstart for system initialization (this is default for Ubuntu 14.10 as far as I remember), he should check whether file /etc/init/tty1.conf exists or not.

Hallo,

somehow I managed to get TTY working while searching for a solution for another issue. The actual /etc/X11/xorg.conf is giving me TTY1 to 6 in 1920x1080 with the actual driver 346.47.
The bold lines are modified, partially by nvidia-settings manager writing Xorg.conf partially manual entries.
The modeline in Monitor section must be defined according to your hardware: just type: “cvt 1920 1080 75” to get the values Xresolution x Yresolution x Refresh rate. All entries should match your desired resolution.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 346.47  (buildmeister@swio-display-x86-rhel47-01)  Thu Feb 19 19:19:45 PST 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LGD"
[b]    # 1920x1080 74.91 Hz (CVT 2.07M9) hsync: 84.64 kHz; pclk: 220.75 MHz
    Modeline "1920x1080_75.00"  220.75  1920 2064 2264 2608  1080 1083 1088 1130 -hsync +vsync[/b]
    HorizSync       83.0 - 83.0
    VertRefresh     75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980M"
[b]    Option	   "DynamicTwinView" "FALSE"
    Option         "metamodes" "1920x1080"[/b]
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
[b]    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "1920x1080_75 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"[/b]
    SubSection     "Display"
        Depth       24
	<b>Modes	    "1920x1080_75"</b>
    EndSubSection
EndSection

Hello,

I’m having the exact same issue with my ROG G751jt (970m, 1920*1080p), and I can’t replicate your solution, it doesn’t seem to work.

What framebuffer are you using? Did you change another file except xorg.conf?

Xorg.conf should not effect on framebuffer driver. The thing with framebuffer drivers is, that resolution for it is read only. So If framebuffer driver chooses mode that is not compatible with your card/monitor compo, you lost all tty:s/plymouth and you can’t do anything to change it on the fly. To change that resolution you have to manipulate grub’s config and kernel initframs. The way how you do this depends on your distribution(especially init system: systemd, sysv, upstart etc.).

For systemd, arch wiki has some how-to:
https://wiki.archlinux.org/index.php/uvesafb
Ubuntu’s(upstart) and it’s derivates usually works with this how-to(sysv and openrc might work this way too):
http://www.tuxgarage.com/2011/01/fix-ugly-plymouth-usplash-in-ubuntu.html

For starters check first your current framebuffer resolution:

cat /sys/class/graphics/fb0/virtual_size

And compare it with resolution of grub console’s vbeinfo command. Or if you have uvesafb driver you can get supported modes by:

cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes

If that does not work, generic framebuffer modes can be listed with:

cat /sys/class/graphics/fb0/modes

double post…

I followed everything as in http://www.tuxgarage.com/2011/01/fix-ugly-plymouth-usplash-in-ubuntu.html but it didn’t work. Now plymouth does appear instead of the grey screen before, but after 15 seconds, the screen flashes black, I only see the loading dots. Then I see nvidia’s logo, and the login screen. tty are still completely blank.

I have uvesafb installed but

cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes

cat: /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes: No such file or directory

Do you have optimus laptop? I’m not sure how that works with optimus, framebuffer driver might be intel’s and xorg is running with nvidia. Not sure how healthy is that combination, should be ok though…

So what is your current framebuffer resolution:

cat /sys/class/graphics/fb0/virtual_size

Has there folder for uvesafb:

ls /sys/bus/platform/drivers/uvesafb

If not be sure that module has loaded:

lsmod | grep uvesafb

And check the kernel logs i.e.:

dmesg|grep vesa

There are couple things you should check and try with grub config file. There should be no vga= resolution mentioned anywhere, that’s for vesafb driver not uvesafb. Try to add GRUB_GFXPAYLOAD_LINUX=keep under the line GRUB_GFXMODE=, if I recall it correctly, especially efi mode bioses needed it. You can also try that with GRUB_GFXPAYLOAD_LINUX=text, it disables plymouth and shows you starting processes like the old days. Oh and always when you do changes in that file(/etc/default/grub), don’t forget to run update-grub as root(i.e. sudo update-grub).